Welcome to discussions

Quick Suggestions

  • Brotherhood396
    1 posts

    Hi i am a bit confused why you haven’t fixed this glitch yet I looked to help me fix this glitch some one posted about it 2 months ago and it still hasn’t been fixed I put Tedmund down nothing happens I am still confused on how you create games but never fix the problems if anyone knows how to fix the glitch then pls help me

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    @brotherhood396 Thanks for reaching out with this. Our team is aware of this issue and are investigating a solution at this time. We ask that those affected by the issue create a new ticket and attach a copy of their save game files to it for review. If you'd like, post your case number here after the case is created so we can ensure things are in the right place! 

    Official Response
  • Noximotopia
    1 posts

    May I know is the bug gonna fix anytime soon? As I have a problem with the quest, I never recieved the quest at all, but I still can progress, when i put down tedmund that's no cutscene... please advice on it

  • guest-u6oibn0P
    1 posts

    Same issue here.
    I got really frustrated and tried to THROW him on the ground......

    Guess what?! It flipping worked! 😄

  • guest-9wcVOwKU
    1 posts

    Cannot progress Carry Tedmund. Xbox 1. Also my email needs to be corrected.

  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    Hello @but_skeptic,

    Thank you for the update and apologies for the delayed reply.

    I just checked your case and I can see that the information provided have been passed on to the development team. Once we have an update, we are going to let everyone know through the patch notes. Apologies for any inconvenience caused by this.

    @guest-9wcVOwKU - sorry to hear that you are experiencing this issue as well. Can you please contact our team and provide us with your save files with this link? As you mentioned that your email needs to be corrected, I would advise getting in touch with our team as well, as they will be able to verify your account ownership. Thank you!

    If you have any additional questions, please let us know.

    Official Response
  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    Hello @guest-u6oibn0p,

    Thank you for the update! I'm glad that this issue has been resolved for you. Happy gaming and if you have any additional questions, please let us know.

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    Hello all,

    I apologise for the double post. I would just like to let you all know that we have merged together several threads about being unable to progress in "Puppets and Prisoners" together into a single Megathread. Creating a Megathread allows us to keep all information and updates from an investigation in a single place. I apologise if any ongoing discussions have been disrupted by this.

    If you are encountering trouble in this quest, please can you provide us with the following information:

    • What exactly is the issue you have encountered in-game (such as interacting with/carrying Tedmund, or the quest not continuing after arriving at the rendezvous point)?
    • What was the last quest you successfully completed in Cent? You can check this in the "Completed Quests" log.
    • Please include a video that demonstrates the issue you have encountered in "Puppets and Prisoners," as this is very helpful for the ongoing investigations.

    We can then forward these reports to the development team as they investigate these reports further.

    Thank you 😊

    Official Response
  • TheNorom
    1 posts

    I have encountered the glitch that I just can't interact with tedmund in any way. I've tried chasing him away so I was anonymous. I've tried shooting him but still - no change.
    Interestingly I have encountered the same error with Aethelswith!
    As far as I know it happens if you have activated several pledges before finishing each arc. I restarted the game from an earlier save for Aethelswith and that fixed the bug. However I am NOT goin back that far back again for Tedmund.
    Quite frankly it is unacceptable for a GAME BREAKING bug to persist for such a long time. I find it baffling that we the players not only have to test the game but also find where the actual problem lies. Fix it.

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    Hello there @TheNorom! Welcome to the forums 🙂

    I'm sorry to hear that you've encountered trouble when interacting with Tedmund and Aethelswith. Thank you for taking the time to share your report with us. I understand that after reloading an earlier save, you were able to interact successfully with Aethelswith, but you are still unable to interact with Tedmund. Is this correct?

    To help us to take a closer look at this issue, would you be able to send us a video which shows the following:

    • Your quest log and your current quest objective in "Puppets and Prisoners."
    • That you are unable to interact with Tedmund to progress further in the quest.

    Can you also let us know if you have hit the bard NPC prior to trying to interact with Tedmund?

    We can then forward this report to the development team for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details