Welcome to discussions

Quick Suggestions

  • 0 Likes/32 Replies/2049 Views
    2 posts

    @mbelleb17 This is exactly what is happening to me as well.

  • FullMaxJim
    3 posts

    UPDATE: This has happened to me with a couple of other world bosses who hold wealth loot since. I think the boss wealth system seems to be bugged across the board and needs fixing entirely...

  • Meithas
    3 posts

    I've cleared the shipyards. I got the chests in the boat, the tower, and the basement. There's one more remaining, and the map point is to a spot of empty land in front of a house. It looks like I was supposed to loot the treasure off a body, but there's not a body to loot.

  • Ubi-Swaggins
    Community Manager 429 posts

    @alanna234 I am sorry to hear you are having issues with this treasure.

    Can you drop a screenshot showing which treasure?

    Official Response
  • CmdShepard93
    4 posts

    I went back to the Shipyard again.
    This time other then last time I used Odins Eye (changed the Symbol form the dot to the Ingots) befor killing and looting the NPC and this time the Symbol disappeared and was counted tho my wealth progress.

  • Cmgsters
    1 posts

    @paulkneipp I’m having the same problem. Have you fixed it?

  • Meithas
    3 posts

    In case anyone comes across this later, I solved the problem by leaving for long enough that the whole zone reset, and killing everyone again. The wealth that was supposed to drop the first time did drop the second.

  • JupiterJonesAus
    7 posts

    I have the same issue with a NPC in Vinland. I left it several days and returned and he's still lying dead on the ground with the "wealth" icon but can not collect.

    Is there a workaround?

  • mjreid91
    1 posts

    Can't complete the raid in Haervik Shipyard. It's telling me there's still an ingot. I've killed everyone and been everywhere, even underground. Been online too, I hope this gets fixed soon!

  • Ubi-Borealis
    Ubisoft Support Staff 4112 posts

    Hello there,

    I've merged together several threads about being unable to collect the wealth in the Haervik Shipyard. By creating a single thread, it allows us to keep all information and updates from an investigation in a single place. I apologise if any ongoing discussions have been disrupted by this merge.

    As we have had no new reports that the wealth in Haervik cannot be collected, this issue has been marked as resolved. If you are still having trouble collecting the wealth from Haervik, please can you provide a video that shows the following:

    • That you have the latest Title Update installed on your platform. You can check this in the right-hand corner of the main game menu.
    • That you are unable to collect the wealth from Haervik Shipyard.

    We can then pass these reports along to the development team for further investigation.

    Thank you 😊

    Official Response
  • MerdockMoe
    1 posts


    This is, by no means, resolved. I have just raided this shipyard for the second time, and there is no drop for the ingots. I downloaded the most current update three days ago, and still have this problem. Perhaps another update is needed to fix what appears to be an ongoing bug.

  • Ubi-Borealis
    Ubisoft Support Staff 4112 posts

    Hello there @MerdockMoe! Welcome to the forums 🙂

    I'm sorry to hear that you've been unable to collect the wealth from Haervik Shipyard. Thanks for taking the time to share your report with us within this thread. To help us to take a closer look at this, would you be able to send us a video which shows the following:

    • You have the latest Title Update installed. You can check this in the bottom right-hand corner of the main game menu.
    • You're unable to collect the wealth from Haervik Shipyard.

    I'd recommend uploading the video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a link within this thread. We can then forward this for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics