Welcome to discussions

Quick Suggestions

  • Balla_Jazzuz
    100 posts

    @ben1281 Regarding the missing wealth, have you been to the island far west? That place don't show any icons before you get there, and right behind a large arena you find a wealth. That was my last wealth to find in Asgard. When it comes to the missing mystery you can google their locations (trophy guides) and find out what mystery you miss as a back up plan 😉

  • Ben1281
    2 posts

    @balla_jazzuz but how come theres no yellow or white mark on the map to show where the wealth or mystery is

  • Balla_Jazzuz
    100 posts

    @ben1281 About the wealth I suspect it to be too far from the nearest viewpoint, and I have no problem with some of them not being automatically popping up on my map.
    Like the artifacts where you have to be pretty close to force the icon to appear. Mysteries pops up more easily like the wealth icon so it's odd you haven't found the last one.in Asgard.

  • Caedem-hun
    9 posts

    @balla_jazzuz There is an option to get back here if i want to?

  • jeje_71
    71 posts

    @caedem-hun yes, you take a potion in the seer hut and you can go back when you want.

    also, not all mysteries and wealth are available before you finished some quests, i explored the map very early and had to go back later for to get them, like wealth and mysteries in the little island on the middle of the map.

  • Balla_Jazzuz
    100 posts

    @caedem-hun
    As @jeje_71 said, you have the possibility to go back whenever you like.
    So you may go through the whole story without collecting all wealths and mysteries in one run like I did.
    One tip: Don't rush The Big Finish mission, take your time all the way through and make sure Loki is not disguised as Freyja before entering the cave, this mission have bugged out for a lot of people...

  • dosgatos
    4 posts

    Orange mist blocking path to last treasure in Asgard. Quest line has been completed as well as every mystery except the offering.

  • RainbeauRanger
    24 posts

    @dosgatos have you been to Jotunheim and completed that but and then returned to Asgard and bound the wolf?

  • mpalmpalm
    1 posts

    *******SPOILER (MAYBE)*****
    I just finished the well mission and I'm trying to swim to shore to talk to loki . The game is freezing every minute. I have the saved menu pulled up and clicked square, but now I have to wait 3 minutes to click yes.


  • dosgatos
    4 posts

    @rainbeauranger
    Have not been to Jutonheim yet.

  • someClone
    1 posts

    I'm also having this same problem. Nothing I do will move the two part shelf in front of the chest. The save seems to remember the positions of the various shelves, not even leaving Asgard will cause the room to reset.

    This is not the only place this has happened to me either. I can't move the shelf inside the back door to the burning cottage where you have to try save Dandelion Puff.

    I'm going to be really upset if I can't platinum the game because of something this stupid. I'm 40 hrs in so restarting is not an option.

  • Apollo.187
    1 posts

    On Asgard in the Utangard Chasm Area, I tried getting to the chest with one of the Ymir Tears in it, the crevice at the very entrance where the Giants where you have to move the objects to be able to get to it. The moveable object just infront of the chest is stuck in position and I cannot move it in any direction. I tried Saving, then reloading the game, as well as leaving Asgard and coming back, and nothing seems to be fixing it. Please help.

  • Loulabell6
    1 posts

    Hiii

    can anyone help with the orange barrier on the cave in Asgard? It’s in the far left of the map and I’ve completed everything in Asgard apart from this last wealth which will complete my last mystery. I’ve saved and reload over and over too, come out of Asgard and back again but it doesn’t seem to work.

    Thanks in advance 🙂

  • alphamachina
    42 posts

    @guest-vvfbnoof It's a bugged map marker. The tear will be available during a quest later on.

  • RainbeauRanger
    24 posts

    @dosgatos that’s why you can’t get the last tear stone. You need to complete Jotunheim and then go back to Asgard and finish the story arc there. There’s another thing to do after finishing Jotunheim

  • dosgatos
    4 posts

    @rainbeauranger
    Then there is another error going on. Because my game let me gather all the wealth and make the offering in Asgard before heading to Jotunheim. My roommate’s game on the other hand is the one having the issue. I’ll advise them to go on to Jotunheim. Thanks for the help

  • TanukiKaska
    1 posts

    If you exit and restart the game the murderer with the key should spawn near the entrance to the chasm.

    I've found this fixes most bugged quests, treasures etc in the game

  • Xaledin
    8 posts

    I need a tear from a locked chest in Asgard, but the Jotun NPC with the key icon over their head is friendly to me, and i can't injure him in anyway to loot the key.

    I loaded a WAY older save and was able to attack him just fine. So i feel like my game glitched at some point during the story there.

    Here's a clip: https://gamerdvr.com/gamer/xaledin/video/117542110

    I have finished the story in Asgard and Jotunheim, don't know if this makes them friendly or something, but story wise i don't think that's the case.

    I also went back to North West Jotunheim and on the East side of Asgard and all the Jotun NPCs are friendly to me.

    Anyone else?

  • EarendilLorien
    3 posts
    This post is deleted!
  • MrDJ4nderson
    2 posts

    I have the exact same problem. I have 29 tears, yet I have 30 X's on my map. What a joke this game has been. I literally haven't experienced this many bugs since Bethesda. Ubisoft just forever tarnished their reputation and I will never pay full price for any of their games again.

Suggested Topics

Community Details

138
Online
220.1k
Users
37.2k
Topics
184.4k
Posts