Welcome to discussions

Quick Suggestions

  • Th44ne
    3 posts

    I've progressed further in the game, and found there is a second fight with Fenrir. That may be what's holding me up from opening the Orange Door.

  • hroozenbeek
    1024 posts

    @th44ne @supanova23 I ran into the same problem at first too, but after completing the quests in Jotunheim and returning to Asgard for the final fight with Fenrir, the area was accessible. So you'll have to be patient.

  • jpslaby29
    1 posts

    I am also having this issue. Ubisoft, please fix!

  • Th44ne
    3 posts

    @hroozenbeek Yep! I bested Fenrir, collected the tear, and completed Asgard. On to Jotunheim.

  • rui__pereira__
    2 posts
    on my map all ymir's tears do not appear and i cannot interact with the mysteries in Asgard, what to do?


  • rui__pereira__
    2 posts

    on my map all ymir's tears do not appear and i cannot interact with the mysteries in Asgard, what to do?
    I opened 29 chests, but only counted 28, on the map, only 29 treasures appear.

  • CeleritasMortem
    1 posts

    Same here. I've completed the entire Asgard story line, only 1 wealth (the tear) and 1 mystery (turning in 30 tears) remain. Yellow wall of fog blocks access to the final tear. I don't recall fighting Fenrir in this location, however. I do remember fighting the wolf Loki has since claimed as his son early on prior to this. On XBOX One X.

  • flash6933
    1 posts

    Same issue here

  • Highphan
    12 posts

    a couple of things i think of,

    1) is proceed through the main quest line until u see it (theres the last one where u need to get the builders paint) or the Island where Fenrir is on.
    or
    2) if u have a manual save at the start asgard when your at your throne and reload to that save.

  • HMLOWE1988
    1 posts

    Please Help! I’ve completed both the Asgard and Jotunheim arcs. Before I went into Jotunheim and completed that arc, I gathered 29 of Ymir’s tears from around Asgard. There was no barrier at the cave behind where you fight Fenrir. I collected that tear and then went to Jotunheim. I completed the Jotunheim arc and turned in all of the blood stones before leaving to come back to Asgard and fight Fenrir. Now, I’ve fought Fenrir and defeated him, but there are no wealth spots or tear spots on my map. I’m stuck with 29 of Ymir’s tears and no way to progress. How do I fix this? I’m level 367 and playing on Xbox One Series S.

  • LedoveeeKladivo
    64 posts

    @hmlowe1988

    And have you done Mysteries quest in Asgard? One of them (the one with deers) will give you one Ymir stone 😉

  • guest-8D1avAaI
    1 posts

    I am also experianceing this issue.
    PS4, version 1.1.1

  • CJM26_
    1 posts

    @jdspafford67 same problem for me. How can you guys release a game with such a good story and then not solve the most basic glitches!?

  • guest-wNwE2Myp
    1 posts

    I cannot access the chest behind the shelf. I try to pull the shelf back but it gets stuck for no reason. There is nothing blocking it's way.

  • Wigramic
    6 posts

    How is this still not fixed? I want to finish the game. Any updates?
    @Ubi-Woofer

  • Dylan1984fab
    1 posts

    Hi, I'm experiencing a bug for quite a while now in the game.
    In AC Valhalla when i'm in asgard I tried to collect al the Ymir stones. In the area Utangard Chasm there is a chest thats reachable through a crack in the wall. Behind that there a a few stone shelves you need to move. The problem i'm experiencing is that i cannot move the shelf in front of the chest. I have not seen many people that are experiencing the same bug. Just a few, but it would be great if you could fix this bug or workaround. I'm Playing on the ps5 with the latest software and AC Valhalla is also updated to the most current version.

  • MrLodiDodi
    6 posts

    Update 1.2 has been released today, but this is still happening.... are you serious? 😞

  • ubi-smash
    Ubisoft Support Staff 762 posts

    Hey everyone! I am extremely sorry this thread is only being updated now. Our team has not been able to reproduce this issue in the 1.2.0 updates, but please don't hesitate to send us a video clip here of the issue still appearing after updating the game so we can share it with the game team to further review.

    Official Response
  • Emmet1000rr
    2 posts

    So I’ve beaten Fenrir and it says I’ve completed the Asgard saga but still can’t find the 30th stone. Is there something more to do I’m not aware of?

  • Emmet1000rr
    2 posts

    @emmet1000rr never mind I went back and followed the deer

Suggested Topics

Community Details

64
Online
191.1k
Users
31.9k
Topics
160.8k
Posts