Welcome to discussions

Quick Suggestions

  • Gold0nion
    5 posts

    I went back and fought the Builder again. After defeating him I went straight to the cave that had the last Tear. I could get in this time. Then I went through the door to England.

    Maybe the fact that I couldn't find the last Tear and left Asgard only to come back later to look again, could be the issue.

  • charsco
    3 posts

    Spoiler**

    The first main mission in Asgard is glitched for me, I chose Thor to cross the bridge with me to close the gate. Thor has disappeared and it won’t let me close the gate. Level 64. Before this I collect 28 tears. If I choose an earlier save I loose almost 30 hours of game play 😞
    Any idea how to reboot the mission without loosing
    Anything?

  • icarusdignata
    2 posts

    So I have 29 out of 30 ymir's tears. There's one remaining in a locked chest that I can't open because I'm missing the key. I've killed everything in the surrounding area, and still no key.

    I went and checked videos online, and I see that it is indeed a key that should be given on looting an enemy. So this looks like a bug. Can you all fix this please? I don't have a savegame from before me killing the enemies here.

  • icarusdignata
    2 posts

    @icarusdignata

    Figured out a workaround. I saved the game, then loaded the game I just saved, causing a respawn of all the enemies. Upon respawn, the key was immediately shown on an enemy outside the courtyard.,

  • StachuOpPl
    3 posts

    F**k it! i`m an idiot chest is blocked until you start quest witch is in cave. then chest will spawn

  • Hecate_95
    1 posts

    I have been running around collecting the ymir stones but I have come across a problem. Next to utangard chasm there is a viewpoint. When you eventually jump in to the pond you find a cave with orbs that need to be moved and then pointed onto a compass so that the floor drops and you drop into the water to collect ymir's tear stone. I have done all of this yet the floor will not give way. Please fix this

  • unseenredhawk86
    1 posts

    Hey i have chest bug can you please fix it undefinedundefinedits the last one i need to have 30

  • guest-h8ibGd46
    2 posts

    I can't move the closet en get the last stone of Ymir by utangard chasm

  • FedonPV2014
    3 posts

    I got to Asgard and after finishing all quests i woke up from leaving at the gate. Then i got back in Asgard and did a few stuff and left again through the eye icon on the map. After that i decided to get all the wealth and mystery events in Asgard so i went back and did everything except one. The last wealth location is far left on the map in an arena like area but the entrance to the cave is blocked (which is my first issue). After trying to figure it out i decided to let it go and i was ready to leave Asgard but when i open the map to go back to england the wake up eye icon was gone, so now i can't leave. I can't load a previus save as it si about 3 hours old and even if i go back (which i tried) my 1st issue still exists. Meaning that i still can't get the last treasure, although the wake up icon is there. Please help!!1

  • alphamachina
    42 posts

    The chest on this island is bugged. The yellow point shows up on the map and the compass, but does not show up with Odin Sight (there is no yellow glow denoting its placement in the world where it should be underground), nor is it actually physically there in the cave despite standing directly at the 1m point at the same verticality. Literally nothing here. I've looked above and below ground with Odin Sight and it doesn't see the yellow glow, so either a yellow compass indicator was placed in the wrong spot, or the compass indicator is correct, and somehow the chest itself is either bugged out or was never placed. Either that, or this is meant for a future quest and somehow that has become bugged. I've no idea as I'm only a couple steps into the main questline in Asgard (just after bringing the water to The Builder)



    undefined

  • kassper-71
    2 posts

    [Bug] the one at Utangard Chasm were you need to move the obstacles. The last one is bugeed and wont move.

  • BigYetiii
    3 posts

    @golblin2014 I have this issue also, and i have completed the entire arc.

  • BigYetiii
    3 posts

    So, I am completely unable to collect the final tear as the entrance to the cave is blocked by a orange mist. I have completely finished the Asgard storyline, awoken from the elixir and have gone back to asgard with no luck. This is infuriating. I have watched a few YouTube videos and apparently Fenrir is meant to be bound there but He hasn't spawned either. I've tried reloading previous saves. please help!

  • BigYetiii
    3 posts

    @iiviolettoii I have the exact same issue and have tried all methods to try and fix it with no luck yet.

  • srdj_69
    1 posts

    Its a cave where a golden light is blocking the entrance, where you defeat the big wolf. I saw on youtube that defeating the wolf will give you entrance but not in my case

  • falcontree
    1 posts

    @guest-h8ibgd46 dude savage! Did you excape? luckily I saved before have as the ice giants owned me I was only level 20 😅 so I’ve left the brew on the table till I level up

  • Shadoe_Drake69
    1 posts

    I have all icons on the map completed in asgard, but I only have 29 tears. Any advice would be helpful.

  • xxbongserpentxx
    1 posts

    I have stumbled across and issue regarding ymir's last tear. There is an orange barrier at the cave entrance by the arena

  • Roka.
    1 posts

    @acemanspiff13 I've finished the story arch and still have the same problem. Or is there more to the arch that needs to be unlocked after you "leave" for Jutunheim?

  • Z0M81_NINJA
    1 posts

    I have defeated fenrir as well as the builder. The cave that is meant to be accessible after killing fenrir still is being blocked by a barrier that sort of looks like wind? Very frustrated, please fix, I’m one stone and one mystery away from completing Asgard.

Suggested Topics

Community Details

125
Online
196.5k
Users
33.3k
Topics
166.5k
Posts