Welcome to discussions

Quick Suggestions

  • Stixengebretse
    1 posts

    I found it just above the cave opening, laying dead. But hey, fix it. Also took some pictures of it. PS4

  • ThiagooLGangreL
    3 posts

    The Skal to Your Wealth Mystery World Event mission is not working. The bear that is to the west of the mission site is not showing up there.

    To complete the mission, you need to take a plant called lichen from the pit on the side of the NPC that delivers the mission and kill the bear in a cave west of the location described by the NPC that delivers the mission.

    Arriving at the site, the bear is nowhere to be found. Since the first update, the bear has not been prevented from collecting the item "bear testicles" to be delivered to the mission alchemist NPC.

    The Skal to Your Wealth Mystery World Event is located in the Ledecestrescire region, just north of the city of Repton.

    Console: Xbox One S

  • beyondevilgood
    3 posts

    PS4 Player on 1.1.0 Patch

    Can't finish the Ledecestrescire Mystery/World Event titled 'Skal To Your Wealth' because the bear (and Bear Testicles) are completely missing from the cave West of the small house.

    I have left the region and come back to try it mutliple times throughout my current 60+ hours and still no bear. Each time I have spoken to the NPC again before hand to see if that would help. Please fix!

  • Holyris
    3 posts

    @diploidhelix Hello
    no there is no mark, it just a dead bear laid around near the cave
    for me it was south east of the cave and there were 2 npc standing and not moving in front of the bear

  • diploidhelix
    15 posts

    @diploidhelix found it. Just like others it was near the camp but I found it in bushes towards where the guy you are supposed to deliver to.

  • Live_Force
    1 posts

    @ubi-swaggins This quest is glitched for me also. I drank the potion and woke in the cave. When I return to the alchemist there isn’t a speak option to complete the mystery.

    I am on Series X

  • guest-9DMbil0f
    1 posts

    Ive been playing this mission for about an hour. No bear. Found the lichen just fine. Cave is there. Enemies galore walking through the field for no reason whatsoever. Deer and board are attacking me left and right. No bear. No bear carcass. Saved and reloaded mission with no luck. Turned console off and back on with no luck. Came back a day later. Still no bear.

  • BIOROBOTH
    14 posts

    @guest-9dmbil0f
    Same here. Playing on PC

  • blakie1987
    1 posts

    Please fix this, it’s stopping me from completing the game.

  • aliendaddy73
    2 posts
    This post is deleted!
  • aliendaddy73
    2 posts

    I am currently having the issue where you cannot find the bear in Ledecestrescire. I have reloaded the mission SEVERAL times. I’ve completed EVERYTHING within valhalla. I still cannot complete this mystery. There is no bear. I have uninstalled & reinstalled this game. I’ve earned every single trophy. This mystery is stopping me from getting the platinum. I would be more than happy to show pictures & videos to prove this. At this point, other than completing the game, I have been working on this mystery alone for 3 days. Three. Days. I’m not trying to sound demanding, but I’m getting really upset over here. This would be my first platinum. I’m on PS4 here.

  • flyingpope345
    3 posts

    @ubi-swaggins I am having this issue now on Series S. I killed the bear not knowing it was part of a quest and the corpse stays where it died while the loot and mushroom in the cave respawn. The boars and bandits in the area have also respawned but no bear. This has been a reported issue for month, how is it not fixed?

  • sinders
    1 posts


    @ubi-swaggins
    I have just encounted this bug and unable to complete it…. When I go to the cave the bear is already dead. ☹

    have tried a few thing like save and reloading, coming back a few hours late but still not working. Please fix!

  • Ubi-Borealis
    Ubisoft Support Staff 3839 posts

    Hello there,

    I've merged several threads about being unable to locate the bear in "Skal to Your Wealth," which prevents the completion of the world event. Creating a single Megathread allows us to keep all information and updates from an investigation in one place. I apologise if any ongoing discussion has been disrupted by this merge.

    I'm sorry to hear that you are having trouble locating the bear in "Skal to Your Wealth." The development team have been investigating this issue further, and are interested in collecting additional videos and save files.

    If you have been affected by this issue, please can you provide us with a video that shows the following:

    • The Title Update you have installed on your platform. You can view this information in the right-hand corner of the main game menu.
    • You are unable to locate the bear at its den. You may need to check the surrounding area, as the bear can wander off and be defeated by other NPCs in the world. I would recommend making use of Odin's Sight and Synin to show that the bear is not visible in the surrounding location.


    Additionally, please can you ensure that you have an up-to-date save file uploaded to the cloud.

    We can then forward these reports to the development team for further investigation.

    Thank you 😊

    Official Response

Suggested Topics

Community Details

142
Online
217.9k
Users
36.7k
Topics
182.4k
Posts