Welcome to discussions

Quick Suggestions

  • ACEMONT420
    3 posts


    I currently am having the same problem. The game is buggy and froze while playing, once I restarted the game Gunlodr was stuck outside the grotto and wont engage the quest to walk up the visit her father.

  • ACEMONT420
    3 posts

    The game froze while I was finish a feast to remember quest. And once I restarted my xbox i was no longer able to finish the quest.

    Gunlodr is sitting outside the grotto and Im unable to get her to move or interact with me. I cannot move forward with quest arc until this problem is resolved.

    What can we do?

  • ACEMONT420
    3 posts


    I have had the same problem as well, just that my xbox froze during gameplay. I had no power outages or anything of the sort. This is very frustrating as I have saw plenty of responses to other issues but they havnt seemed to respond to this one in any of the posts.

    @Ubi-Mark Can you help us out with a response please? Isthere anything we can do to continue the quest arc?

  • pstocco
    Original poster 2 posts

    After a couple months being gone, came back to my post and tried this; it worked for me thank you!

  • UbiKoality
    Community Manager 440 posts

    @ACEMONT420 @BeautifulMama06 Hi there! I'm incredibly sorry to hear that both of you encountered this problem in Assassin's Creed Valhalla, and that it has impacted your gameplay. Thank you for letting me know what you have tried on your own to get this resolved! Just to confirm, have you defeated Suttungr, but the quest still does not end? Would either of you be able to grab some videos exhibiting the problem here?

    Official Response
  • UbiKoality
    Community Manager 440 posts

    @acemont420 Also, I wanted to let you know that I merged your separate post here for better visibility and reporting purposes. 🙂

    Official Response
  • gh0stofsp4rta
    1 posts

    I was following Gunlodr from her lab all the way up and once we had finished the conversation with Suttungr the game crashed for me.

    I briefly got to see the progress bar and all the feast activities I had to do but ever since nothing works anymore.

    I've already collected every wealth across all areas of every map, finishing the jotunheim questline is the last major thing that I have left for a 100% trophy achievement.
    Can't interact with any spices in the kitchen, any npc outside in the hall or drink up the mead myself to empty the cauldron (I tried).
    Also read that you could trigger the boss fight if you went to the vault but nothing happens.

    I'm playing on PS4 with the latest update, I've tried previous saves but the issue remains.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @gh0stofsp4rta Hey there, and all whom may be experiencing this issue. Sorry to hear this still shows up. Our team is aware of this issue, but would like more information. Like UbiExcellent said, we'd like to grab the save game files of those who are experiencing this. You can send these to us by attaching them to a newly created support ticket with our dedicated support team!

    Official Response
  • guest-pHrMhALH
    2 posts

    So I started the quest a feast to remember and got pretty far on it I’m at the part after entering gunlodrs grotto and we are supposed to ride up to the feast hall. But now she’s glitched out and won’t move or follow me or get on the mount at all and multiple of my game saves are deleted. I play on Xbox and I really do not want to restart my profile because I’m pretty far in the game already.

  • guest-pHrMhALH
    2 posts
  • Yurixtaka
    9 posts

    @ubi-wan A quick fix would have been to let us restart a mission, heck I'll even take a new game plus. I've been waiting patiently for this to be fixed, but at this rate with no real update on a fix for my issue I might as well ask for refund to Microsoft. No reason why I can't complete a quest that bugged out and there is no reason why there isn't an option to restart the mission in 2021. I was looking forward to 100% this game but at the rate this is going I won't be able to unless I start over from scratch which I won't be doing. I get asking for a save but it's ridiculous for me to re buy the game on a different platform just to get a copy of my save.

  • devilrmarines
    2 posts

    i am having the same glitch there nothing there no matter what i try

  • Strikes12
    1 posts

    Same thing is happening to me. Loki just seems to be chilling in the 'Well' entrance. I run inside, the giant face says nothing. No markers any where. No idea what hasn't triggered, or isn't triggered. --GAMEBREAKING

  • OutrightPage091
    2 posts

    Objective is gain access to mead. Nothing shows up on my map. After the cutscene with Gunlodr when you are supposed to follow her she doesn’t move and is a statue. The mission can’t progress any further due to this bug. Does anyone know how to fix this?

  • BNasty83
    1 posts

    I am stuck on a Feast to Remember chapter 4. Can not follow Gunlord. Just stands there and no other mission markers. Stopped the game once before following her on the horses. Then when went to play again could not progress. Please help.
    Game is completed otherwise besides this. Very frustrating.

  • Boobulon
    1 posts

    Haven't seen this one mentioned in the known issues list. I have defeated Suttungr but the quest won't finish. He just sits there down on one knee and repeats his lines over and over and nothing happens 😞 Playing on PC.

  • Ubi-Mark.
    Ubisoft Support Staff 1361 posts

    Hello @Boobulon,

    Sorry to hear that you are unable to complete ''A Feast to Remember''.

    I just checked it out for you and I can confirm that this issue has been already reported to the development team and it's currently being investigated. Once we have an update, we are going to let everyone know through the patch notes.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • ubi-smash
    Ubisoft Support Staff 823 posts

    Hey @outrightpage091, my apologies for the delay in getting back to you. We have received similar reports of players unable to complete A Feast to Remember and forwarded this to our team to further investigate. In the meantime, please keep a lookout on our thread here for further updates from our team. We thank you for your patience and understanding as our team works on a fix moving forward.

    Official Response
  • Zmajski68
    1 posts

    @creads82 Did you fix it? I think making a manual save, and then restarting the game should work.

  • Sloromiro
    3 posts

    my game crashed when I met the female Jotun during this quest and now it won’t let me continue. I’ve played most of the rest of the game and every time I go back to Jotunheim she just stands there. I’ve also tried to activate world events in Jotunheim and find wealth but they also will not start or in the case of the wealth, cannot be found.

Suggested Topics

Community Details