Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • The_Nah
    1 posts

    I escorted Hunwald into the sewer portion of the city during the 'Homecoming' quest; once he gets into the large room he won't come back out of the sewers. You can go forward further but he cannot leave when you get to the climbing part at the end of the sewer. I've tried everything to get him to path back out of the large room, he simply won't do it. Is there any way to hard reset the quest line? He doesn't fast travel with me and cannot leave. This is essentially locking my soft locking my save file.

  • Ubi-Borealis
    Ubisoft Support Staff 2111 posts
    Best Answer

    Hello there!
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Homecoming" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
    If you are still encountering issues with "Homecoming" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
    Thank you! 😊

    Official Response
  • SAMaas73
    1 posts

    In the process of doing this quest and taking Hunwald to Lincoln, I went into the sewers under the town to search for treasures and sneak him in to town. There are 2 entrances into the sewers. I took him through the sewers to the other end of the sewers and there is a steep incline there with scaffolding against the wall. I climb up the scaffolding, but Hunwald will not follow me and just stands at the bottom of the incline.
    So I figured, guess I’ll have to take him back out the way we came in, so I work my way back to the other entrance, only to find out that he won’t walk past a certain spot near that entrance.
    When I get near him the quest shows where I have to take him, but if I move away from him it directs me back to him because I’m supposed to escort him home.
    This is on PS4 btw, not sure if anyone else has had this issue but didn’t see a post about it.

  • corpuscavernosa
    2 posts

    @stef23462 Yes, same here.

  • corpuscavernosa
    2 posts

    So the quest "Homecoming" in Linconshire appears to be broken. In the quest, Eivor must escort Hunwald to his father's house. We got there, failed a stealth attempt which resulted in the guards being dead, then entered the house. It said "you must become anonymous" and I attempted to do so. Didn't work, and Hunwald is still standing in front of the house, despite reloading saves (I didn't make a separate one prior to this quest), the game, completing other quests/arcs, etc.. I'm unable to do anything further.

    Is there a workaround or fix incoming?

    Thank you!

  • SofaJockey
    169 posts

    @stef23462 Which county is this quest in?

  • rodolfo230293
    1 posts

    got the same problem. I went away and Hunwald disappeared. He is not even on the map I tried changing quest but afterwards the quest remains bugged.

  • Mythical_Morty
    2 posts

    @sofajockey Lincolnscire

  • Mythical_Morty
    2 posts

    I have this same exact problem i have no idea on what to do.

  • FAalltheway
    1 posts

    I'm having the same issue. They only solution I can think of is to go back to a save point prior to entering into the sewer.

  • EraakRagrob
    2 posts

    While escorting Hunwald to Lincoln, I came to go trough Roaring Meg's spring, and we got stuck. He cant climb the scaffolding at the end, and he wont follow me back. Please make him climb.

  • carpeva
    1 posts

    I am stuck in Hunwald's Homecoming quest. I went though the bandits lair underneath Lincoln and he won't go forwards not backwards. What can I do? I cannot advance.

  • EraakRagrob
    2 posts

    If you lead Hunwald into the Roaring Meg's spring cave, he cant climb the scaffolding at the end or follow back out of the cave. So he is stuck and i cant finish the quest, please help.

  • cosnowboarder
    1 posts

    Having the exact same issue on PS5. Game is now completely stuck.

  • X87xPrimex78x
    1 posts

    Same problem here (PS4) and not the first issue. Pretty disappointing...the fun in this game is destroyed by dealing with these unfinished gameplay issues...

  • deathbybundy
    1 posts

    @eraakragrob same here man, im about 5 minutes from imploding 😂

  • Deathgrim666
    5 posts

    Here is a link to a video on what the bug looks like:

    I was doing the mission escorting the npc when my game crashed, and when i came back the quest was bugged. For some reason its bugged on the ui and the npc is stuck. I contacted support and was told to wait for a update, that was dec 11th. I was told that going back to a older save would help but when i got the bug I just pledged to another arc hoping that the quest would reset.

  • erosfortones
    1 posts

    @deathbybundy Oooph, same. Anyone find a solution to this?

  • chfbupers420
    1 posts

    I am playing Valhalla on Xbox One, doing the quest "Homecoming" (Where you have to escort Hunwald to his home in Lincoln. However, when I get there, I just get a message saying "You must be anonymous". I can still save my game, so I know I'm not in a combat state... I tried killing all of the enemies in the surrounding area, but when I went back to Hunwald's home it's still telling me I need to be anonymous. Any idea what I can do to get past this so I can progress in the game?

  • samarr08
    4 posts

    I reported a bug on the quest homecoming where hunwald was stuck in his father's house case number 14192911

    I have been told to refer to this forum and with the new bug list found today this hasn't been included for some reason. Is the list on this forum the full list of bugs or only ones that are reported through the forums.

    I've been stuck on this since the end of January and want to finish the game I have nothing else to do other than river raids

  • samarr08
    4 posts

    Glad to see I'm not the only one however does not fill me with hope that this was reported in November yet this is still not fixed. Looks like this won't be fixed in the near future

Suggested Topics

Community Details