ubisoft discussions

Quick Suggestions

  • Kattai78
    3 posts

    @wally188188 I'm having a problem with Raculf completing. I've looted every chest, even the minor ones, killed the soldiers and no completion. We're all standing around picking our noses. Very frustrating.

  • Kattai78
    3 posts

    @ubi-raziel I'm stuck with no completion in Raculf Monistary. Looted all the chests, killed all the soldiers. No completion. I did sneak in and get all the chests I could prior to sounding the raid horn, so I'm not sure if that is what glitched it. Just my experience.

  • timmyd111
    10 posts

    In Sudwella Monastery I got the problem of I have collected all the chests but the sequence has not registered as raid completed so I can't complete a new Home to proceed can this be addressed in the next update?

  • frozzbytes
    1 posts

    Suddenly raid seems bugged. I was at Saint Albanes Monastery to do raid, and press J when prompted, but my crew will not move from their longship. Tried reloading saves, restarting, did not help. This same thing happened at another raid location.

    Tried starting the raid from the longship, but there is no gold circle to start the raid at all.

    Getting frustrated. I've encountered a lot of bugs in this game..

  • NeedleNerd
    11 posts

    @wally188188 Same problem here, one door remains shut and I can't call a raid again to finish the last door/chest to complete the raid at Raculf.

  • JIeMypylllka
    23 posts

    @@frozzbyte Yes, Yes. I have the same problem too. The RAID can't start from the river, because there is no "Golden circle", my crew is dead (I have 4 archers and 1 Dag, u can watch my topic: https://discussions.ubisoft.com/topic/83691/dead-crew/1?_=1607330139817), BUT!! I can start a RAID and open chests with Dag, when I use the horn, while standing next to a closed door.
    Dear ubisoft! Please fix the raids, cuz this is the most fantastic thing you've ever come up with in Assassins creed games.
    Ubisoft. If u continue to ignore it I will mark everyone who has the prefix Ubi, like @Ubi-Baron in every my post. Im sorry, i understand that u have a lot of reports, but this is the RAID. The main thing which should work correctly by default.

  • sgrieve2507
    1 posts

    I'm trying to raid sancta Maria Abbey, if I start the raid from land via the wheel menu the enemy's attack me but my raid party do not turn up even though my ship turns up they all stay on the boat, if I start the raid from the boat same problem my raid party won't leave the boat?

    1 posts

    I can’t complete Saint Albanes Abbey, Evesham Abbey, and Sudwella Monastery. Done everything at all three and killed everyone. My character will even say we’re all done here but it can’t complete them. Anyone else have a workaround?

  • Noia325
    4 posts

    Raids "Brimclif Monastery" and "Cicestre Abbey": both have no golden start circle on water and cannot be started manually - on sounding the horn on land, the crew does not show up at all, or when landing with longboat, they remain sitting in the boat and don't move.

  • dazerker
    3 posts

    @timmyd111 having the same issue

  • LongKev
    1 posts

    If you leave the area and then return... You can go to the chest and manually start your raid from the dpad menu and a guy automatically runs in to help

  • guest-hGYBSqSc
    3 posts

    A case of the missing ale - location marker wrong. Also the issue of the actually cask of ale missing.

    also for ur comment about the raids it’s not just location - when Starting a raid my crew members don’t turn up! Takes multiple tries and restarts and even then it’s faulty.

  • IGNYY-_-
    1 posts

    I just went thru the same issue in Runcwuda Abbey in Hamtunscire, the way I solved it was clicking "Fast Travel" back to your long ship and then restarted the raid. Everything was looted and everyone dead, except the chest that needed to be open. Hope it helps someone else.

  • sithis411
    1 posts

    @ubi-raziel I have some unopened doors from a previous raid but Eivor can’t start another raid. Frustrating!!

  • hibiitt
    2 posts

    Currently I have the raid completed but the icon remains on the map and the raid can still be started again. However all loot is already looted.

  • dazerker
    3 posts

    I have killed every enemy and opened every chest at the Sudwella Monastery, but the raid won’t complete. It’s preventing me from fully upgrading the settlement and it’s all I need for 100% please address this

  • Doomsayr87
    1 posts

    I still can't do this. I've done everything looted all chests freed all prisoners. Everything and on my map it still has the raid symbol. Something this simple shouldn't be an issue. Ubisoft needs to hurry up and catch up with bugs before they start with the expansions and all that. So many times I've had to work around bugs in this game. Smh.

  • Iamdeewinner
    1 posts

    I opened the large chest in Wyther farm in river severn and got nothing no cargo gear or weapons. Anybody else have that problem?

  • InkdZomB
    1 posts

    Today while on river Severn area several times when I opened a chest no loot has spawned. Tried reloading the game and issue still happened.

  • Magpye
    16 posts

    @inkdzomb on replaying the raids on the river Severn, after opening the first chest in any location, Eivor say that’s everything and the crew start to return to the boat even though there are still some of the large chest still available to open. This is frustrating as I’m trying to get the bracers of Saint George armour peace which is the 2nd of two peace’s of gear that I need.

Suggested Topics