ubisoft discussions

Quick Suggestions

  • Neacroe
    8 posts

    I have this issue as well. Completely unable to access the mastery challenges. If I slow walk into the old lady, I can actually slide her around, but she still doesn’t respond or allow me to talk to her. If I fast travel away and come back, she stays at the last spot I pushed/slid her to. She is stuck without being able to interact with her after I experienced a buggy version of the fight cutscene months ago during the Sigrblot festival. Perhaps this will help the devs by giving an idea of the state that the NPC is stuck in during this glitch. And that the festivals seem likely related as well.

    If you look at the completion rates for the mastery challenge trophies, they are abysmally low. This is likely because many many people have this problem, but since the quest says “progress further”, most people likely have no idea it’s actually bugged, and just think that they haven’t progressed far enough. I only realized it was a game/content breaking bug once I finished the main story, saw it was still messed up, and looked it up to find the glitch was common.

    I am very disheartened to be unable to play this mode, as I would really like challenge and from what I understand, these challenges are like the arenas from the previous games. I want to be able to fight lots of enemies but the only time I can do that in-game is in spread-out locations with relatively small amounts of enemies, and once I’m done clearing out a place the enemies are all gone.

    I have been excited to “reach the point in my progression” where I could play the mastery challenges for pretty much my entire play-through since the Mastery Challenges were introduced, and after beating the main story just the other day, I came back and was excited to finally be able to play these challenges only to find out that my game was bugged the entire time, and that I may NEVER be able to play them. There’s legitimately nothing I can do other than re-play the entire game up to that point, which doesn’t help Me at all since everything I’d gain from the challenges would not go to my main character. I enjoy farming and I got to power level 450+, and even if I play the challenges on a new character (IF it would even work on a new character), none of the rewards would translate to my main character anyway, so there’s really no point other than for the trophies.

    I had planned on 100% this game, and this glitch that prevents me from even accessing an entire game-mode and its challenges completely ruins that goal, and my excitement I’ve had this entire time that I thought I was slowly making progress towards this goal.

    If we could at least get a response from the team that it is an issue they are working on, I would at least be able to continue other areas of the game knowing that at some point it will get fixed and I would be able to complete my goal of 100% the game. All of the Ubisoft responses to this thread say “they have been made aware of this issue”, yet they have been saying this for well over HALF A YEAR and this hasn’t even been added to the list of “known bugs”. As others have stated, by Ubisoft’s own bug prioritization protocols, major bugs like this that prevent progression should be a high priority, yet they have yet to even officially acknowledge this as an issue that they are working on or are even aware of to begin with.

    If the Valhalla team could at least officially acknowledge this bug, and reassure us that it will be fixed at some point in the future, it would go a long way towards alleviating a lot of our frustrations here.

    There have been several other threads of people complaining about this issue from over 6 months ago, and this one thread alone is approaching 200 posts. What do we have to do to get some sort of acknowledgement that they will work to help us? You’d think that after spending months of their time creating things like these Mastery Challenges, they’d be upset that so many players are completely unable to access the content at all.

  • Neacroe
    8 posts

    @ubistorm I am also in the same position as everyone else here, completely unable to access the Mastery Challenges because Hildiran is stuck at the Freyja statue, unable to be interacted with. I just made a long post that you can read, but I did not tag anyone. I’m making this second reply because I wanted to tag you so that someone from support was directly notified. For my full explanation and thoughts/frustrations, please read my recent post on this thread.

    Thank you for at least updating us that we have not been forgotten, but until this at the very least gets added to the list of “known bugs”, it doesn’t matter how many times we are told “we are forwarding this issue to the development team” since it’s been over 6 months with not a word.

  • cherishpride
    16 posts

    At this point, not a SINGLE ONE of my friends have been able to play this mode. Not a SINGLE ONE. Still being on the "this information has been communicated to our development team" step six months later is a travesty.

    Expect a massive boycott of they next DLC/season pass, you're dangerously underestimating how many people are impacted by this glitch. People like us who would make posts on reddit or this forum are in the vast minority. We bought the season pass so we stayed on board for year 1, don't expect us to get on board for year 2. Unless you make an official acknowledgement of this glitch soon, don't even bother announcing new DLCs to be honest, you'll miss out on 5-6% of sales, to be conservative. No one cared about Tombs of fallen and River raids, if you had any metric you'd know that. No one cares about festivals. Mastery challenges is the one everyone got excited about. Check your metrics.

    I believe that such a proportion of players not being able to play the most popular mode during six months REQUIRES at least some form of official communication, even if it's some corporate BS, at least to feel heard. This is disrespectful at this point.

    I've contacted an influential AC vlogger on Patreon. To paraphrase our discussion, he has tried to stay positive despite the multiple glitched releases over the years and was the only one who spoke in terms of appeasement when Unity got botched, he hasn't been impacted by this glitch but many of his friends have and he'll probably make a video about it soon. So there's that to look up to, maybe the negative coverage will hurt your sales and make you honest, since candid feedback had no impact.

  • Neacroe
    8 posts


    I am on PS5 so I would have to figure out how to export my saved videos from my PS5 to PC in order to send it here. It may take a while. The previous videos have pretty much expressed the same exact issue I am having except for displaying the fact that Hildiran can be slid around by slow walking (fast walking of anything else will not move her) into her. And that is pretty much exactly as described. She slides in the direction I push her with my slow walk without moving her feet or changing what she is doing. She always retains the original angle she is facing while in front of the Freyja altar. I tried pushing/sliding her so far up the road going up towards the meteor strike location that we left Ravensthorpe (the Ravensthorpe music changed), and then tried to run her over with my horse. She actually jumped out of the way and it made her walk back to her spot in front of the Freyja statue, but unfortunately at no time did it ever allow any dialogue with her. I tried this at another time and was unable to reproduce the effect of getting her to return to her usual spot by running her over with her horse.

    Throughout my progress in the game, I frequently checked back with her. I have now finished the entire main story and am max level with several mastery points.

  • Neacroe
    8 posts


    I really appreciate you sharing how many others are having this problem. As I have said before, because the bugged quest says to “Progress through the story”, it is extremely likely that a huge number of people have this glitch but have no idea because they will just assume they are missing a progression-related requirement. I know I did until I decided to risk spoiling stuff and looked up the information and realized it was a bug.

    You are also absolutely correct that only a tiny minority of people ever end up vocally complaining and reporting the bugs they experience. The Mastery Challenge trophy completion rates are ridiculously low, like fractions of a percent low. I bet this is because most people have ZERO access to this content. I want to (or at least wanted to before realizing I may not be able to because of this glitch) 100% this game, but I will tell you with absolute certainty that I am not playing through 100-200 hours worth of content that I already played to start a new character just to play this mode, especially knowing none of the rewards or experience would be granted to my main character.

    If we knew this was going to be fixed, I would have no problem continuing my progression in other areas until it gets fixed. But because they REFUSE TO ACKNOWLEDGE this issue, I have little hope for any of that to be possible.

    Regarding your communication with the Valhalla content creator - them making a video about this issue would GREATLY help our cause, since it would likely wake up a ton of people who are experiencing this bug but don’t know it due to the cryptic quest “progress more” instructions. Anything that can raise awareness about this issue would be extremely helpful. So if you could help convince them to make a video about it, that would be wonderful.

    Thanks for helping us keep this thread alive and hopefully keep the pressure on for them to finally fix this ridiculous, extremely frustrating bug that blocks access to a huge portion of free content that the developers likely slaved over for months, only to have almost nobody play it due to a pathetically small/stupid bug that the Ubisoft support staff either fail to make them aware of, or due to some other ridiculous communication issues.

  • cherishpride
    16 posts

    @neacroe thanks for the love. I'm just waiting for today's change log. You know what's the worst thing ? I actually wrote down a preemptive workaround in the first pages of this thread, but I only discovered it after the glitch reached its final state. If during the very first time you talk to her and she attacks you, you randomly mash every button on the controller, the glitch doesn't appear.

    They even acknowledged my workaround in this thread. The least they could do is publically acknowledge the glitch and this workaround so that most people don't stay trapped as we are.

  • cherishpride
    16 posts

    It's a real shame because I absolutely LOVE the direction the games are going in. Yesterday's announcements were INSANE.
    And I do appreciate mods on this forum, they're just following orders. But it's really frustrating as a long time fan, who even considered accepting a job offer at one point, to be ignored.

  • furbe8
    5 posts

    Not fixed in 1.4.1
    Very disappointing.

  • Neacroe
    8 posts

    @furbe8 Yes, still not fixed. This is becoming absurd. Why are they just blatantly ignoring this relatively huge bug but fixing small things almost nobody is experiencing and adding new things without fixing entire sections of inaccessible content? What on earth are they doing!?

    I also love how every patch has some
    sort of “fixed ____ mastery challenge trial”.

    It’s like a slap in the face. I don’t even know what those trials are. Or what it’s like to play them. I would LOVE TO, but I CAN’T because they refuse to acknowledge this infuriating bug.

    I’m glad this seems to be picking up steam because the more people coming forward and complaining about this bug, I would hope the more likely they are to do something. Although it honestly doesn’t seem likely, it seems more likely they are just blatantly ignoring it. Why? I have no idea.

    the support staff in this thread have been saying “rest assured, the team are aware of this issue” for 6 months now, so either they are not telling the truth and the development team has not been made aware, or the development team is just ignoring us.

    If they are having trouble fixing the issue, that’s totally fine - but if that is the case, why not have it added to the list of “known bugs” or acknowledge the issue in any way? It boggles my mind!

  • cherishpride
    16 posts

    UbiQuB3 @UbiQuB3 can you please add this to the known issues ? I don't understand what's the holdup, it's been six months

  • AmIEvil1974
    8 posts

    @corvosilver I have the same problem and even after the new update 1.4.1. it still doesn't work. I cant even get the woman to talk to me now. I have a video and will put it up soon . I hope they get this fixed.

  • KaiCaiel
    1 posts

    @amievil1974 same, VERY frustrating

  • Assassin.lvl.10
    2 posts

    @amievil1974 same been having issues

  • Assassin.lvl.10
    2 posts

    @ubistorm hopefully it can be fixed soon. I've been stuck on this mission for months. With no way to activate the quest.

  • Neacroe
    8 posts

    It looks as though support has completely abandoned this entire thread as well... they haven’t even bothered to respond now, which is funny because this thread is actually picking up pace now that people are realizing that the quest instructions are actually a bug and that they also have this issue.

    Absolutely abysmal support Ubisoft. You do realize that all of us responding here are the ones that actually care the most about these games and are big fans, right? As stated before, only an extreme minority take the time to log on and report bugs. For every one of us there is 100-1,000 people having the same issue. There are almost 200 replies to this thread. You do the math...

    All we ask is that this bug be officially acknowledged. That’s all!!

  • MattRicc2
    22 posts

    @neacroe last week marked 6 months since the Mastery Challenges were released, and since this bug has been reported. Still, no patch or fix for this HUGE bug.

    I'll quote what I wrote back in september:

    Curious to note that, according to their Update Pipeline post (News - Ubisoft Connect) an issue like this one (that prevents the player from playing a whole series of activities) should have an high priority:
    Flagged issues are categorized and prioritized based on frequency, severity, and/or player impact. (E.g. Main quest progression blockers will generally see a higher priority than side content or quality of life issues)
    At this point, I wonder why I keep waiting for a patch that nobody knows when (if?) it will arrive. This issue is not even listed in the "Known Issues" (which I know that doesn't include all the problems that are under investigations, but again - this one should be a top priority one according to Ubisoft's own post).

    I'm part of the Mentors Guild program, and I've shared the existence of this issue both in the Guild channels and on the Reddit "Tech-support" threads.

    I can't even saying that I'm disappointed and frustrated by this issue, after all this time (6 months!) I don't care anymore about this whole Mastery Challenges stuff...

  • AmIEvil1974
    8 posts

    @amievil1974 Here is my issue I have a video

    . I have reported this and have yet to get an answer. I really hope they get this fixed

  • Neacroe
    8 posts

    @mattricc2 Wow that’s crazy, that even being involved in those groups they refuse to even acknowledge this. I suspected from the beginning that the fact that this bugged quest has the misleading “progress through the story” description/instruction, meant that it probably duped the majority of people into not realizing they were experiencing this issue. Now that suspicion is being confirmed, and every day more and more people are reporting this bug (and as I’ve said before, we are only a tiny fraction of the amount of people experiencing this), and yet still NOTHING is being done.

    This thread grows larger and larger every day and yet not only do they not have the common courtesy to acknowledge us, the support team has in fact stopped responding to us altogether - a drastic regression from months ago when they would at least respond to lie and promise us that “the issue is being looked into!”.

    In other words - as the amount of people reporting this huge bug increases, their response is not just to continuously ignore us, but to actually decrease their communication and contact with us.

    WHAT IS THE PROBLEM?! WHICH OF THE TWO OPTIONS IS IT: Is the development team not receiving this feedback, or are they knowingly ignoring us? These are the only two options. Which one is it?

    For gods sake, which one is it?!

  • azullFR
    2651 posts

    there is another option :
    (approximative English + shortened option)

    knowing the best developpers whom worked on Valhalla and, or Far Cry 6 have gone (a priori Ubisoft hierarchy mistreats its employees and customers), the few ones still working don't know how to fix without breaking something else

Suggested Topics