ubisoft discussions

Quick Suggestions

  • MattRicc2
    23 posts

    @azullfr that's funny because I was just reading a report regarding this situation.

    "One developer recently said a colleague currently at Ubisoft contacted them to solve an issue with a game, because no one was still there who knew the system."

    Inside Ubisoft's unprecedented "exodus" of developers - Axios: (https://www.axios.com/ubisoft-assassins-creed-great-resignation-aef86e61-75a8-4446-8ad6-f2c58bd0b730.html)

  • azullFR
    2942 posts


    👍 👍 👍
    exactely what I suspected !

    Many, many thanks to you for this link 🙂

  • wan1097
    1 posts

    @ubistorm fix this bug. really frustrating.

  • Neacroe
    8 posts

    @wan1097 This appears to be one of the most widespread and severe bugs this game has to date, and it is also becoming one of the most reported. They have been lying to us, saying “We’re so sorry you are experiencing this bug! Rest assured, the team is aware of this! As of now there is no timeframe for which this bug may be fixed!” For over 6 months now. Over half a year.

    They have been straight lying to us for over half a year now... as of now there are NO plans to fix this bug any time soon. At least several months ago Ubisoft support pretended to be listening, now they have stopped altogether. Don’t get your hopes up - Ubisoft does NOT give [censored] about this enormous bug because they don’t make any money from it. It will likely never get fixed.

  • petebaldwin
    16 posts

    @neacroe We waited just under a year for a bug fix to something that made the game unplayable for some people on PC. Fine before the 1.1.0 patch and broken until around a month ago.....

    They did the same there - responded, said they were working on it, came back a few times and then abandoned the thread for months. This will get fixed but it’ll be well into next year and it’ll happen by accident. The mods won’t know it’s fixed but will respond with “glad to hear it works now” as people start responding to say it’s working.

    i think an assumption is made that the mods on here have good communication with the devs but that’s clearly not the case so they are left with no tools to help us. They just report what we’re saying and appear to get nothing back. What can they say but “we reported it for you.... they’re working on a fix.”

  • CplMacUSMC
    1 posts

    @ubikoreanbbq I am also having trouble I’ve beaten the game, hunted all of the order all to 100% completion except for the Paris and Ireland dlc. Done w/ Vinland and Sykes island too. Still just say progress through story to continue. No videos to share

  • KplusU
    4 posts

    Ok same problem. Literally have everything completed and it tell me to process through the story. Please help!!!

    2 posts

    the mission is bugg, not imposibilite continued, i need help, the mission my comment, continued why the mission main.

  • KplusU
    4 posts

    @kplusu @ubisoft please help. I play on x box(wished it was a ps but whatever) I have literally 36 day 15 hours and 9 mins with just the challenge of the gods trophy (and the Beowulf mission also) holding me back from 100%. Please help. Really put a lot into this one to not complete and don’t really have money to do anything else.

  • Silveira1989
    2 posts

    Hey bro,
    I have the same problem, not solution yet. In this time, do you have a solution?


  • IainW
    1 posts
    Love the game it’s great. I have over 170 hrs completed just about everything the game has to offer. Except the challenge from the gods. I did the cutscene to fight the lady ages ago before I was ready and the game still says “progress thru the main story”. Ive looked all over the web for ways to fix it but nothing seems to work. There others like me that are frustrated from not being able to do the mastery challenges. I made a report about the bug and took break from the game hoping there be a update that would fix it. I got no response and it’s still here. So is the bug going to be fixed or is just impossible on my current save. I just want to enjoy the game without having to start entirely from scratch. Please reply 🙏🏽

    I have exactly the same problem, I've restarted, respawned, progressed through the story line, stood on my head while singing the national anthem backwards and spun round 3 times saying Beetlejuice and still I cannot trigger this quest, she just stands their praying and almost taunting me.

  • Richard_093
    4 posts

    The dialogue with the old woman always cuts off short. Can't go further.

  • deJongh1997
    9 posts

    @silveira1989 Sorry, but no. I haven't. And @Ubi-Mushy or @Ubi-Orion are not giving updates out for it either.

  • Zaizo12
    2 posts

    Any update on a future fix? Will it be this month at the very least?

  • UbiStorm
    Ubisoft Support Staff 710 posts

    Hello everyone. I do apologize for all of the frustration caused by this particular issue, as well as the delay in getting any updates out to you guys. At this time, I don't have any new updates to share, but I did want to reassure you that the team investigating this issue is still looking into it. It hasn't been forgotten or ignored.

    Any updates we receive from the team about this issue will be immediately posted here for everyone to see. Thank you so much for your continued patience and understanding!

    Official Response
  • deJongh1997
    9 posts

    @zaizo12 Who knows??

  • Ubi-Borealis
    Ubisoft Support Staff 6075 posts

    Hello there @deJongh1997,

    I'm sorry that you've encountered this issue with "A Challenge From The Gods." As mentioned by my colleague @UbiStorm, we don't yet have any updates to share from the investigation into this quest. We have reached out to the development team to see if we can get any new information. Once we have any more details to share from the investigation, we will let you know within this thread as soon as we are able to. Additionally, any future updates will be posted within the News & Announcements forum via patch notes.

    Thank you 🙂

    Official Response
  • KlayMan_VR
    4 posts


    Seven month and still no fix on this subject and not even a slight information regarding a potentiel timeline ?!
    Please assume that no one is working on it because you have no ressource to put on that problem and we'll be fixed and won't wait seven more month for nothing.
    Or that this bug is number 645 on a todo list thats keeps getting longer and it's not a priority at all for now, that I can understand to be honnest.
    At least we'd know what to expect.
    I hope I'm wrong but seven month of "investigation", come on. It's so frustrating for all the people like me who have spent a lot of time on this game and can't access the late game.

    Anyway, happy new year (to add some positivity in my message haha)

  • Ubi-Borealis
    Ubisoft Support Staff 6075 posts

    Hello there @KlayMan_VR,

    Happy New Year to you as well! 🙂 Thank you for taking the time to share your experience and feedback regarding the investigation into "A Challenge From the Gods." I'm sorry to hear that this issue has impacted your gaming experience for several months now, and has caused you some frustration.

    Please note that the Player Support team doesn't have visibility on how long an investigation may take, and are unable to speculate on any ETAs for resolutions. I would like to assure you that the development team are currently investigating this issue further, and that we have reached out to them for any updates from the investigation that we may be able to share with you all within this thread.

    Additionally, any future updates for this quest will be shared via patch notes posted within the News & Announcements forum.

    Thank you 😊

    Official Response
  • cherishpride
    16 posts

    Hello guys, happy new year!

    I totally understand your lack of data on the investigation. I believe the main point of frustration for posters in this thread is the fact that this issue is STILL not in the known issues thread, which is provoking some fear and uncertainty. A lot of us feel like this issue is getting quietly pushed under the rug. Could you please add that issue to the known issues thread as a sign of good faith ?

Suggested Topics