Welcome to discussions

Quick Suggestions

  • 10 Likes/178 Replies/7616 Views
    Ubisoft Support Staff 550 posts

    @cordonananas07 Hi there! Thanks for reaching out about this issue as well! As mentioned above by @Ubi-Borealis, this is still under investigation! I recommend keeping an eye out here, as well as our News and Announcements thread for updates. Thank you so much for your patience!

    Official Response
  • ChronosVrS
    3 posts
    This post is deleted!
  • ChronosVrS
    3 posts

    On PC with same power level as @I__DONT__CARE , can't remember the meteor scene played right, but now I've already finished the main story and she keeps stuck on the statue without any prompt to speak, also the quest log changes in Norway, abut on England shows to "progress through the main story"

    Here is my case: https://drive.google.com/file/d/1UKYQYzr6MEDb0H121S2TGlPCZCLPHreA/view?usp=sharing

  • Danzo117
    1 posts

    I am also stuck on the ‘A challenge from the gods’ bug from Assassin's Creed Valhalla. I have put 260 Hours into this game, and i have completed EVERYTHING in the game, and also in the DLC from Ireland and France. 100% completed, and i still get the message “progress through the main story”, although i have completed every last thing in the game!

    This Glitch has been a known issue, from early June 2021, and it still has not been resolved! Almost three months has past, and the Ubisoft Mod, disingenuously informs us, that the issue has been sent to the relevant body. 

    If this glitch is even fixed by Christmas, i would be surprised! 

    Almost 3 months, and still the issue persists! The Ubisoft Montreal Coders could simply reset the ‘A challenge from the gods’ Mission. This would not take long to implement, but we will be bluffed and bluffed that they are looking into it. 

    I have lost absolutely all confidence in Ubisoft Montreal, and in the Ubisoft Connect application. Constant Crashes from Ubisoft Connect (about 2 a day on average), but I will post this nonetheless. i will never make a purchase from Ubisoft Connect, Ever Again! The Platform is very temperamental, at best, and completely broken at worst. 

    How does your company expect its customers, to have any faith in the Platform, if they can not fix a major bug in almost 3 months. This very poor customer service, would not be tolerated over at STEAM. 

    Personally, i do not believe that the relevant Coders, over at Ubisoft Montreal, have been even made aware of this issue, ‘A challenge from the gods’ bug, which is why i am going to contact them directly. 

  • octagonal3
    7 posts

    @ubistorm This has been going on since JUNE. It is high priority bug according to Ubisoft's own definition - stops progression of the quest completely !

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there @ChronosVrS, @Danzo117 & @octagonal3,

    I'm sorry to hear that you've been unable to progress further in "A Challenge From the Gods." Thanks for taking the time to share your reports with us. The development team are still investigating this issue further, and we don't yet have any updates to share with you all at this time. Rest assured that as soon as we have any new information to share with you all regarding this quest, we will let you know within this thread.

    Thanks for including a video in your report, @ChronosVrS! We've passed this along to the development team as part of the ongoing investigation.

    The development team have confirmed that they won't be implementing a "Reset / Restart Quest" feature into the game, @Danzo117. You can read their full statement below:

    Due to the structure of quests within the game, a "reset/restart quest" feature is not feasible at this stage of development. While some quests and world events allow you to walk away or reload your save in order to reset them, this is not the case for every instance within Valhalla. We strongly recommend regularly adding manual saves, especially before and after pivotal moments, to ensure you have backup states to revert to if needed.

    Thanks! 😊

    Official Response
  • the_real_dna
    27 posts

    @ubi-borealis yeah i could load a backup save.. but the amount of lost playtime is huge. dont really feel like doing the complete siege of paris and wrath of druids expansions all over again, which is what I lose (and then some) if I revert back. Ubi makes the assumption that people dont make saves (also thinking thats the perfect solution to every bug), but we do make saves. But as a practical matter, nobody wants to lose 50 hours of gameplay because of a bugged feature. What if you didnt even know it was bugged? What if you started the quest but chose to go do something else in the game for a while.. you wouldnt even know it was broken until you finally came back to the quest. And at that point, its too late. The bug message says "progress further" .. i guarantee so many people took that literally, thikning they just had to keep playing and progressing the story.. until finally it dawned on them "hmmm this doesnt seem right.. ive now completed everything and its still saying that" .. do you see the problem here?

    All of that aside, let's say you go back, you're willing to start over again, you start the quest, and you still can't get past the glitch. Well.. what then? Reverting to an old save doesn't help in any way. Me personally, I've tried hitting random button/keys, but I'm unable to get it to proceed. The only button I've found that does anything at all, it simply speeds through the dialogue and gets to the cutscene a lot faster (same way you normally are able to spam through dialogue quickly) but it always ends the same way.. with the old lady walking back to pray, and you no longer interact with her. Perhaps if there were more specifics on how to get to the fight aside from "mash random buttons" .. im also using keyboard and mouse, not sure if thats the difference, but ive tried pressing all my key binds and nothing helps

  • the_real_dna
    27 posts

    Because I'm on PC and have the luxury of manually keeping backups of the actual save files that are locally stored.. I've got a complete set of saves for all 6 of the play-throughs Ive done.

    This allowed me to do more testing. I loaded up one of my old "100%" playthrough saves that was at the previous max power level, with 76 mastery points on each skill tree branch. This save had not been played since 1.2.0, aside from completing several Sigrblot Festival "quests" in order to get the time-limited items for sale. Neither Seige of Paris nor Wrath of Druids were ever started, as these were added later. I loaded the save, went to the skill tree to let it register all the new skills added in the update (you know, where it goes "ding" on every new skill in the tree).. immediately went to investigate the crash site and the quest proceeded as normal, and I got to play the Mastery Challenge game mode for the first time ever.

    However, I loaded up an old save from current playthrough (about 60 hours back), a save from before the meteor cutscene played. I did the entire Sciropescire arc with Ceolbert and Ivar, added a few skills and power levels (~240), fast traveled back to Ravensthorpe, reported to Randvi, pledged to Cent, fast-traveled to Ravensthorpe (yes, I was already there but I wanted to force a reload of the area), this triggered the meteor cutscene to play, I followed the quest, built Hildiran's house, spoke with her, and just before we were set to fight, she went back to pray (exact same thing that's been shown in the videos posted by others).

    What to do now?
    So.. the questions I have are: How far back do I need to load in order to get this working properly? Is this entire playthrough trashed, and I just have to start over from scratch? I could load a save from 20 hours prior, below 200 power level, play the game and level up to meet the requirements, only to find out that the quest still doesnt work. This is a colossal waste of time, just "hoping" that it will work. Maybe I need to load a save from before I even came to England? But who knows, maybe that won't even work.

    It was was awesome to play the Mastery Challenge game mode for the first time because I think it's a lot of fun. The flipside to this however, is that given how much content is there and available to play, it completely blows my mind that this isnt a top priority to fix for players who can't get past it. You're literally missing out on a pretty significant game mode. For me, I don't want to play it on my "100%" save.. it's not fun when every single thing is done except the 2 DLCs and the Mastery Challenge. I want to play it organically, as I work my way through the entire game. Unfortunately, it doesnt look like this will be possible (reliably) without completely starting a new game

  • bielik01
    959 posts
    This post is deleted!
  • Ubi-Froggard
    Ubisoft Support Staff 829 posts

    Hey @the_real_dna

    I wouldn't suggest to start an entire new game, or even trying your save from 20 hours prior, as there's no guarantee it won't happen again. Of course, you're welcome to try either of those options again if you are enjoying the game enough to want to replay that much content. We just can't say for sure that either of them will help avoid running into it again. As it's something we are aware of, personally I would just wait for a future patch that resolves it. I apologise for any inconvenience caused from it. I know it must be incredibly frustrating.

    Official Response
  • MattRicc2
    15 posts

    New patch will drop tomorrow. Reading the patch notes (Assassin's Creed Valhalla - Title Update 1.3.1 | Ubisoft Forums) the issue with Mastery Challenges WON'T be solved yet. It has been 3 months since the bug was first reported. Still, no update on when we'll get it fixed (is this issue ever going to be patched?)

    Curious to note that, according to their Update Pipeline post (News - Ubisoft Connect) an issue like this one (that prevents the player from playing a whole series of activities) should have an high priority:

    • Flagged issues are categorized and prioritized based on frequency, severity, and/or player impact. (E.g. Main quest progression blockers will generally see a higher priority than side content or quality of life issues)

    At this point, I wonder why I keep waiting for a patch that nobody knows when (if?) it will arrive. This issue is not even listed in the "Known Issues" (which I know that doesn't include all the problems that are under investigations, but again - this one should be a top priority one according to Ubisoft's own post).

    I'll just pretend that those Mastery Challenges never existed 👍

    (Still, no words on if the weapon that was given for the ones that played the mode will be available to the ones that weren't able to play it.)

  • Ubi-Nacho
    Ubisoft Support Staff 749 posts

    @mattricc2 Hi!

    Thank you for taking the time to post today, sorry for any disappointment caused due to this issue being missing from the patch notes.

    I can confirm that the team is aware of the issue, and there is an open investigation to find a resolution. With certain issues, it may not be a case of it's priority that causes delays in a fix, but also it's complexity.

    I would encourage any players experiencing this issue to still reach out with their reports, as the more information that can be passed to our game team the better.
    Apologies again for any frustration this may cause.

    Official Response
  • Knopff
    1 posts

    @ubi-nacho Hello, I have a case that there is no icon for that mission at all on the map, so I even cant start it after I choose it from quest menu. So is there any solution to fix that issue as I can't progress in the game. I have re-installed it but nothing changed. I use PS4 to play that game. Please help.

  • v_for_vern
    1 posts

    As of 1.3.1 this still hasn't been fixed and we are approaching the three month mark since the contents release...

    How about removing the story requirement if you can't figure out how to fix it? Gees

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there @Knopff & @v_for_vern! Welcome to the forums 🙂

    Thank you for taking the time to share your reports and feedback regarding "A Challenge from the Gods." I'm sorry to hear that you've encountered trouble with this quest.

    Just to confirm, @Knopff - have you been able to complete the first interaction with Hilderan following the meteor crash event? Or is the quest missing from your log entirely? Can you provide us with some more information about how far you've been able to progress in this quest?

    The development team are still investigating this issue further, @v_for_vern, and they have not shared any plans to remove any quests from the game. Rest assured that as soon as we have any updates to share with you all from the investigation, we will let you know within this thread.

    Thanks! 😊

    Official Response
  • kronosglide
    9 posts

    ah man, i got this same bug. i had started a new game, (sadly i overwrote me 1st games save) and when i got to this level and started the quest, the fight scene ended abruptly and would just repeat. unfortunately i have no old save prior to the quest line as after i initially started the quest i went in and did a few other arcs and leveled up some more. now however, i can’t talk to her and when in england says to progress further. i’m at power level 254.
    on a ps4.
    also to note besides having the constant new quest pop up ( which only seems to happen is i’m around an avenge quest then won’t go away until i restart the game or do the quest)
    i get a shadow rune and rune of rage repeatedly pop up into my queue after traveling back to settlement. even after selling them( thanks for the silver ) this happens repeatedly.

  • guest-s0Znq8Kw
    1 posts

    @kronosglide I'm not able to play it either, I walk around her and the Y to speak doesn't show up at all, she just stands there facing the alter.

  • kronosglide
    9 posts

    so i was able to go to a cloud save that had further progression and the mastery challenge already started. in addition i download the profile setting for the game to the console, but the new game with the mastery challenge not working, still isn’t working.
    to note in the old game i downloaded from the cloud, i get a rune of life now in addition to shadow rune and rune of attack into my i inventory. i just sell them.

    one more thing to add, still getting the avenge quests that pop up and every time i collect something it pops up to notify. as a work around i’m completing them. turned off tips and messages ( didn’t ignore the pop ups) turned off mini quest log ( didn’t fix it) so only workaround i can see is to complete the quest.

  • kronosglide
    9 posts
    This post is deleted!
  • Ubi-Woofer
    Ubisoft Support Staff 1267 posts

    @kronosglide - Welcome to Discussions, and thank you for sharing your report of this issue here on the forums! I am sorry to hear that you are unable to progress with "A Challenge from the Gods" after the first cutscene due to the fight scene repeating. Would you be able to provide a video showing this behaviour, so that I can compare this to our existing reports and verify if it is the same issue that we are aware of? Your description sounds slightly different to other reports I've read, so it would be helpful to see this footage to make 100% sure.

    Regarding the constant "new quest" pop-ups, this is an issue that we are aware of and is being worked on at the moment. You can find our dedicated megathread for the issue here, and I would encourage you to share your report and experience of the issue there so that we can keep all of the relevant information in one place.

    Finally, regarding the two runes that are repeatedly being added to your inventory - are you able to provide a short video clip demonstrating this behaviour as well, and that it can be infinitely reproduced when fast travelling back to the settlement? A video showing the runes being added, you selling them, then fast travelling away and back only for them to appear agan, would be of a great help to us.

    @guest-s0Znq8Kw - Welcome to Discussions! I am sorry to hear that you are also unable to progress in "A Challenge from the Gods". Just to confirm, is it Hildiran that you are unable to speak to? Is this the initial conversation with her that you are trying to start, or a subsequent one after watching the first cutscene? Thank you in advance for any additional information that you can provide! 🙂

    Official Response

Suggested Topics