Welcome to discussions

Quick Suggestions

  • UNSOLVED Unable to access "Legend of Beowulf" / "The Way of the Berserker" following TU 1.2.2. | POST HERE

    0 Likes/265 Replies/6940 Views
    Ubisoft Support Staff 4150 posts

    Thanks for the update, @ToraxOutlaw! I'm glad to hear that the quests have appeared for you after going offline 😄 Rest assured that the development team are aware of this issue and are investigating what could potentially causing this issue to occur in-game. In the meantime, we ask players to try the suggested workarounds so they can continue the quests as the team look into a permanent fix.

    If the quests don't show in your "Completed Quests Log" after you have completed them, please don't hesitate to reach out so we can investigate further.

    Thanks! 😊

    Official Response
  • ToraxOutlaw
    5 posts

    @ubi-borealis OK, I completed the entire quest chain like I said, reconnected my xbox to the internet, rebooted valhalla and loaded my save. The quests do show up in the completed section.

  • Ubi-Borealis
    Ubisoft Support Staff 4150 posts

    Thanks for the update, @ToraxOutlaw! I'm glad to hear that you've been able to complete all of "The Way of the Berserker." 🙂

    If you encounter any further trouble in-game, please don't hesitate to reach out so we can investigate further 😊

    Official Response
  • Andermen0
    1 posts

    Hi i have problem with the mission of the legend of beowulf. The letter that starts this mission does not come to me. I finished the main plot of the game and the letter still hasn't come. I tried to verify the game files but it didn't work. I also tried to go online to offline mode but still nothing.

  • UbiKoreanBBQ
    Ubisoft Support Staff 380 posts

    @phobi666 Hey there, the team is wondering if you'd be able to accept the quest and then save your game and upload that to the cloud? Please let me know when that's done!

    Official Response
  • phobi666
    13 posts

    @ubikoreanbbq Here you go

    I had this quest initially accepted back when I created the settlement in england.

  • peixeswordfish
    20 posts

    cant see or play Legend of beowulf

    cant see or play Legend of beowulf

    The letter is not at her settlement

  • AlePlay
    522 posts
    This post is deleted!
  • jakl201
    26 posts

    @peixeswordfish It's a Ubisoft connect bug. Go to main menu, click the Connect, open up your overlay, then close it back down. The quest will show back up, even your progress in it. There's a mega thread with this issue you can peruse as well.

  • Ubi-Mark.
    Ubisoft Support Staff 1749 posts

    Hello @peixeswordfish

    Sorry to hear that you are unable to access this content.

    Can you please confirm if you tried disabling and reactivating the overlay. as @jakl201 mentioned, by any chance?

    I also merged your thread with our megathread for better visibility.

    If you have any additional questions, please let us know!

    Official Response
  • Ubi-Mark.
    Ubisoft Support Staff 1749 posts

    Hello Vikings,

    Thank you for your updates!

    I can see that this issue has been already reported and it's currently being investigated. In order to speed up the investigation, can you please provide us with the following:

    • Can you please let us know if you have the Ubisoft Connect overlay enabled or disabled (PC)? If you have disabled it, please can you try enabling it again? Once it's been enabled, please access the overlay in-game via the main game menu to see if this triggers the quests to reappear in-game for you.
    • If you play in online mode, please can you switch to offline mode to see if this triggers the quests to appear in-game for you?

    Many thanks!

    Official Response
  • phobi666
    13 posts

    @ubi-mark You are my hero. Thank you. With this I could continue the Quest.

    I made a video of it for others who might have that problem:

  • Azhrei21
    46 posts

    Unbelievable... It's end of August 2021 and I'm seeing this happen in my game? I just started this game recently. WEnt to england, I just cleared the "lvl 20" areas... Even last night I saw "Legend of Beowulf" and "The Way of the Berserker" icons on the map in East Anglia and they were in my log. I was going to do them today when i start clearing East Anglia. The icons now are NOT on the map, the quests are NOT in my log, going into Ubisoft Connect and then leaving like someone said didn't help, the letter is obviously not in my mailbox at the settlement (and waiting 5 minutes for the loading screen is unacceptable to boot, The PS4 is not that weak, what in the hell Ubisoft? I'm not even going to get into textures not "popping in" until i get 2 feet away... and it seems to go back to normal if i reboot the game.... it's like there's a memory leak).

    Do i have to wait until the game decides it'll let me play them and they pop back up? Fix your **** Ubisoft... DLC quests shouldn't be contingent on connecting to some internet crap. They should be installed on OUR CONSOLE and ready to go at any time... (I read that's the reason for this).

    By the way I'm on PS4 and there's no overlay option anywhere for this Ubisoft connect junk...

  • Azhrei21
    46 posts

    @azhrei21 idk why the edit button's not working this time lol... Now they're both suddenly back on the map (and quest log, Berserker and a Fiend out of Hell)... after wasting an hour on forums and crap trying to figure this out. >.<

  • Ubi-WheelyDuck
    Ubisoft Support Staff 566 posts

    Hey @phobi666,

    Thank you for your update and for sharing this video.

    It is great to hear you could continue the quest.

    If ever we can help in the future just let us know.

    Official Response
  • peixeswordfish
    20 posts

    ok yes I uninstalled ubisoft connect and installed it again
    ok am currently power level
    191 and I have the season pass I got wrath of the druids and siege of Paris
    it says the legend of the beowulf is installed but its not their because I checked the the letter at her settlement and its not there
    I went to the location where the legend of the beowulf is I just see dead cows but no mission story available is there.
    I am currently using PC and I got everything but the legend of the beowulf

  • Ubi-Orion
    Ubisoft Support Staff 681 posts


    Hey there.

    Can you double check that the Ubisoft Connect overlay is enabled? If it isn't please try enabling it and try checking for the letter again after restarting the game and the Connect client.

    Official Response
  • Ubi-Milky
    Ubisoft Support Staff 1113 posts

    Hello @peixeswordfish I am sorry to hear you are unable to access the Beowulf quest.

    The quests you should have available are >

    • A Fiend out of Hell
    • Prey in the High Hall
    • Ever as Fate Must

    If you are unable to find the letter and you have none of these quests available to you in your quest log, can you please try and disable your Ubisoft Connect overlay in the launcher's settings first and switch to offline mode.

    Next, once you have performed these two steps, are you are able to access the quest letter from the longhouse after a night of sleep or meditation?

    If not, please get in touch with us over one of the following links and we will check your account for this content and your save files, to investigate the possible cause further >

    Twitter Support -  https://twitter.com/UbisoftSupport
    Facebook Support - https://www.facebook.com/UbisoftSupportUK/
    Ubisoft Email/Live Chat Support - https://www.ubisoft.com/en-gb/help/contact

    Official Response
  • peixeswordfish
    20 posts

    it worked but only offline
    that doesn’t make sense why offline
    but at least am able to access it
    it should work online ...
    and for some reason my clothes was off
    I had to get a different torso for her
    but at least am able to play it offline
    than when am done I will switch back online thanks...

  • Ubi-Milky
    Ubisoft Support Staff 1113 posts

    No worries @peixeswordfish thank you for your reply and update.

    I am happy to see you are able to proceed and access the quest, but I apologize that you needed to sign offline in order to be able to do this. I will let our AC team know this was the case, as this issue, we are aware of.

    Official Response

Suggested Topics