Welcome to discussions

Quick Suggestions

  • UNSOLVED Unable to access "Legend of Beowulf" / "The Way of the Berserker" following TU 1.2.2. | POST HERE

    0 Likes/265 Replies/6912 Views
    20 posts

    ok thank you

  • RosaKimmie
    1 posts

    I'm currently unable to continue with my legend of Beowulf quest, I tried the ubisoft overlay trick and it doesn't work. I can't go offline as I'm using ubisoft+. Is there anything I can do @Ubi-Borealis ?

  • Ubi-Borealis
    Ubisoft Support Staff 4118 posts

    Hello there!

    I've merged some similar posts into our ongoing Megathread about being unable to access the "Legend of Beowulf" / "The Way of the Berserker" additional quests. I apologise if any ongoing discussion has been disrupted by this merge.

    Thank you for continuing to share your reports with us, and for providing updates if the provided workarounds have helped to resolve the issue for you.

    If you have received the letters to start these quests, but the quest markers have disappeared from your map, please can you try the following steps:

    • Can you please let us know if you have the Ubisoft Connect overlay enabled or disabled (PC)? If you have disabled it, please can you try enabling it again? Once it's been enabled, please access the overlay in-game via the main game menu to see if this triggers the quests to reappear in-game for you.
    • If you play on console (PS/Xbox), please can you open up the Ubisoft Connect overlay via the main game menu to see if this causes the quests to trigger.
    • If you play in online mode, please can you switch to offline mode to see if this triggers the quests to appear in-game for you.

    These workarounds have helped other players to trigger and complete the missing quests. If you're still unable to start the quests after trying these steps, please don't hesitate to share an update within this thread so we can investigate further.

    @RosaKimmie - Welcome to the forums! 🙂 I'm sorry to hear that the workarounds have not caused the quests to trigger for you. Could you please visit your "Add-Ons" to ensure that the content is available for you in-game? Some players have found that visiting "Add-Ons" via the Animus Store triggered the quests to appear in-game as well.

    I understand that you're unable to go offline due to playing via Ubisoft+. If you're still unable to access the quests, would you be able to record a video which shows the content has been installed via "Add-Ons," and that the quests are not present in either your current quest log or your completed quest log? We can then forward this for further investigation. I'd recommend uploading any footage to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread.

    Thanks! 😊

    Official Response
  • CapnKel
    16 posts

    This thread is pretty long so I haven't read it all, thus I have no idea whether this comment will help or not, nor whether the following "fix" has already been mentioned.

    I recently experienced this issue with "The Legend of Beowulf" quest while playing under patch 1.3.0. It had been in my quest log for a really long time and only when I finally decided to do it is when I noticed the quest was no longer there. So I followed the recommended advice of uninstalling and reinstalling the associated DLC (twice) which did not help at all. Then I read a comment somewhere that said going into the in game store is what got it working for them, so I tried that. This didn't work the first time I tried, but on my second attempt it did, probably because on that try I actually clicked on several random things in the store.

    Not sure the following will be helpful to the dev team or not, but one strange consequence of clicking on the season pass in the in game store would cause my Xbox Series X to try and update it's own store app repeatedly which I thought was strange. Anyways I was finally able to do the quest and finish it thanks to the above advice regarding the in game store. I still need to grab "The Way of the Berseker" quest from the Connect app which I haven't gotten around to yet. Hopefully I won't encounter any issues with it. 😉

  • Ubi-Woofer
    Ubisoft Support Staff 1258 posts

    Thanks for sharing your experience of this issue with everyone in the thread, @capnkel, and I'm very glad to hear that the workaround of visiting the in-game store and viewing some of the item pages there worked for you! I hope that you enjoyed completing the quest, and that you're looking forward to playing the game further.

    We're committed to investigating any further reports of this issue with accessing The Legend of Beowulf and The Way of the Berserker, so please do all keep us updated here in this thread if any of you are still experiencing issues. 🙂

    Official Response

Suggested Topics