Welcome to discussions

Quick Suggestions

  • TurkeyMoose
    6 posts

    As expected, this is absolute garbage. I was mildly excited when I realized I had just enough unopened chests left to acquire enough supplies for my next two upgrades at the settlement, which I thought were the last ones, but I was mistaken and I have two more upgrades needing a total of 2400 supplies, meaning I'd need to open another 24 chests, which I definitely do not have left, so I'm screwed like everyone else. I did contact support and was told they can't add supplies to the account and they're "working on it". So I guess we'll be waiting another month for the next patch. 🙄

  • Chibi_Lenne
    2 posts

    Sigh, not fixed at all, I'd already done most of the raids and 150+ hours into the game before I even noticed that I wasn't receiving supplies to upgrade Ravensthrope. Wonder if they'll ever patch that -_- pretty sure I don't have enough unopened chests to upgrade the settlement

  • xAmiellex
    1 posts

    @ubi-mark I have the same issue, worst I think I've opened every single chest, did every single raid and opened every small chest as well. I Can't find the missing 200 supplies. Can't upgrade the settlement to 6, the last one I need to have the platinum trophy.

  • El-Kashi
    24 posts

    @chibi_lenne same problem my friend... it's hopeless ...

  • asjupiter
    1 posts

    Should players who play on 1.2.2 update deserve this BUG?

    2 posts

    I completed the main story and raided all the 19 monasteries/military forts, but I stiil don't have enough supplies to improve Ravensthorpe level to 6. Is this a bug ? If so, is there a possibility to fix it or I'm doomed to stay at level 5?

  • Killswitch311
    1 posts

    Please add Supplies to the shop.

  • Squall57070
    1 posts


    Idem pour moi pour les "materiels" il m en manque 300 alors que j ai ouvert tous les coffres du jeu et même parcouru la carte au moins 10 fois......

    Donc impossible de up la colonie niveau 6.....


  • Matt_Slater
    1 posts

    I have also only been receiving silver from flat chests, at raid locations, civilian locations, everywhere. I have cleared out the map, with only a handful of small chests remaining. If there is no way to retroactively give players the fabric and supplies they should have gotten, then at least make it available to purchase at shops (at the very least if they've completed all raid locations). There's no point only making fabric available at the shop at settlement lvl 6, if the issue that that is addressing, is the same issue that is hindering players from receiving the necessary supplies to even get to lvl 6.

  • ShushuTheFox
    1 posts

    Hey how can I get supplies if I opened all loot and did all raids?
    I missing supplies in order to get to lvl 6 with my settlement

  • Hugoferis
    12 posts

    I still not getting fabric from chest in high level areas, like in Hamtunscire, Glowecestrescire

  • Hugoferis
    12 posts

    @ubistorm @Ubi-Borealis I already made a video about still not getting fabric in high level areas. I opened two chest and only gave me iron ore and feather not fabric. My AC Valhalla version is latest version 1.3.0. Here is the video

  • Satron1ca
    3 posts

    Guess we'll just have to wait another month 👏

  • rtxus
    17 posts

    @vaelnir Technically, they can access to your savegame, they can edit it (even it's by loading it and using the dev console to -additem xyz) so they could fix this. BUT i guess, they dont want to be overwhelmed by thousands of players having this issue now... As i could see, there was a "higher" priority to make all beggars sleep all day so that you cant farm runes to make couple credits anymore.. And since yesterday i get multiple crashs again.. It's a disaster. Gonna play Chernobylite i guess and wait another year for this game being playable decently.

    Ah yes, forgot, i also got now a bug where my poultry requires never ending upgrades..

  • rtxus
    17 posts

    @squall57070 Vu que c'est le forum anglais et que les agents presents ici sont visiblement submergés par les centaines de bugs (les pauvres, je les plains en fait), laisse moi juste te répondre que y a pleins de gens avec le même probleme, le support veut pas (ou comme ils disent "peuvent pas" aider pour le moment) et prient tout le monde d'attendre que le probleme soit pris en compte par la dev team... Donc "patience" comme d'hab 😉

  • Kaionashi13
    1 posts

    @m1iche11 I am literally in the same place, with the latest update I was able to finish the Faith sidequest. But I still need well over 2000 supplies to finish my settlement, and I've already cleaned up the map, no more raids or chests available. I have over 150 hours of game, and quite a few Reda's items, so there's no way I'm starting a new game.

  • Khf73
    2 posts

    It's absolutely incredible to witness a game punish players that played it and looted buggy chests with missing supplies in the past month. To see the lack of effort from Ubisoft to react and make things right for those players is beyond belief. This should not only have been fixed right away - but to not compensate those players that had this issue, is simply unacceptable at this stage.

  • ansgar9791
    6 posts

    no joke wrote the support two tickets about the topic and got the same bot answer back

  • su6431
    7 posts

    @ubistorm no, I still can’t get any fabric after the 1.3 patch from small chest.

  • santhora
    2 posts

    Congrats to the Ubisof team for forcing me to cheat to getting supplies👏 👏

Suggested Topics