ubisoft discussions

Quick Suggestions

  • lordsoth1984
    2 posts

    @ubi-mark
    Thank you for your response, unfortunatly the page give me the only option ofthe "chat" when i select the game for the problem and says that the chat is not aviable...
    any other suggestion?

  • Ryusennin
    164 posts

    It's a known issue since patch 1.2.2. Here's the relevant discussion:
    https://discussions.ubisoft.com/topic/99554/longer-loading-times-following-tu-1-2-2-post-here?lang=en-US

  • Ryusennin
    164 posts

    I've noticed some huge loading times as well on PS4 since a patch or two. From game startup to save fully loaded, I clocked 5m30s.

    But contrary to other users, my PC version (on a standard HDD) has remained the same, about 2m30s.

  • Ubi-Mark.
    Ubisoft Support Staff 2623 posts

    Hello @lordsoth1984

    Thank you for the update and I'm sorry to hear that you were unable to contact us directly through the website.

    Have you tried getting in touch directly through our social channels? It will allow our team to create a support case for you as well and investigate it further for you.

    PS: I also merged this thread with our megathread for better visibility. Thank you for your patience and understanding!

    Official Response
  • JamesLogan491
    139 posts

    On PS4 it takes over seven and a half minutes from the moment you open the application to the moment you are loaded into the map and able to control Eivor. A game like RDR2 takes two and a half minutes. Ubisoft was never the most competent at optimization but this is ridiculous, specially when you consider that any textures beyond 30 feet from Eivor are not even fully loaded, letting us see those low res polygons everywhere, this is even more noticeable in Ravensthorpe where buildings and decorations won't be fully loaded even if you are standing right next to them.

    If you add up the loading times of what I call the end-game cycle it is over 40 minutes of no game play on a 2 hours session, 33% of the game is just loading:

    Loading for going in a river raid;
    Loading for finishing a river raid;
    Loading for traveling to Francia;
    Loading to fast travel between the 5 merchants there;
    Loading of about 20-30 secs when interacting with each of them;
    Loading for traveling to Ireland;
    Loading of about 20-30 secs to sell goods to Azar;
    Loading for interacting with the Ireland trader;
    And finally loading to return to England and start again.

    A third of the game time is spent doing something else around the house instead of playing the game.

  • Ubi-Orion
    Ubisoft Support Staff 1252 posts

    @jameslogan491

    Hey there.

    Thanks for adding your report to the megathread. I can see that my colleague has passed your report on to the team investigating these issues with longer load times. Apologies for any inconvenience caused in the meantime whilst we're looking into this.

    Official Response
  • dilu122x
    1 posts

    Hi. I Have Brand New HDD On My PS4 That Installed Last Monday.Yesterday I Brought Ac Valhalla And I Noticed That In The Title Screen (Press X to Continue),When I Press X It Does Starting Checking Add-ons And It Takes More Than 3 minutes.It Is So Annoying Than The Loading Screens on ps4.In The Other way When Loading SAvegame It Does Take More Than 2 minutes To Load In My Case loading Screens Are Okay But Checking Add-ons Is So Annoying.
    Please Fix This.

  • Ubi-Nacho
    Ubisoft Support Staff 1736 posts

    @dilu122x Hello there.

    Sorry to hear you're seeing long loading times with Assassin's Creed Valhalla. Would you be able to take a look at our PS4 troubleshooting guide, as this offers steps that can help with game related issues such as this one.

    Once you've carried out these steps, if you're still experiencing longer load times, could you please let us know:

    -Is your HDD, the game is installed on, internal or external?
    -How much storage space is remaining on the drive that contains your game?
    -Do you always experience 3 minute load times consistently on launch? Do you find sometimes it loads quicker or slower than this?

    Thank you!

    Official Response
  • SpirantCrayon22
    1888 posts

    Hello ubieveryone

    This is standard for everyone, as far as I can tell. It's most definitely not a PS-only problem. I have to wait several minutes on my Xbox One X. Often true when "fast"-travelling to a different map as well as when loading. I believe it's being investigated for PS in particular so feel it important to keep reminding you guys that those among us who don't use PS have the same issue.

  • bitebug2003
    112 posts

    This is still an issue

    I reinstalled the game to play the Tombs of the Fallen (since I moved onto other games).

    Checking for add-ons takes forever (probably longer than the times I previously stated)
    And the loading into the game took so long that Eivor reached the loading screen boundary (invisible wall)

    With further DLC planned - this will just get worse and there is nothing more off-putting than booting up a game to play but having to wait nearly 10 minutes just to load the game

    Please optimise the game and do something about the constant checking for add-ons every time we start the game

  • GreenMedici
    3 posts

    @bitebug2003 Same issue on PC. I have a gtx 2060 super, 11th gen i5, 16 gb ram, 1tb m.2. Before the update for Tomb of the Fallen/ the festival they added from Nov 11 - Dec 2 the game has been stuttering whenever I use my horse, checking for updates upon booting up the game takes at least 2 minutes, long load times when interacting with NPCs, pretty much long load times when doing anything lol

  • orldan
    120 posts

    Valhalla takes forever to load for me, easily more than 5 minutes total, about 2 just for that idiotic "checking for add-ons" that occors every time the game launches. Also, during the load I get "new controller device connected" every time, which is very fascinating considering I use only mouse and keyboard. Why does this game take so long to load? And what's the point of this endless addon check every time?

  • Ubi-Oxavo
    804 posts

    Hello @orldan and welcome to Discussions.

    Sorry to hear the game is stuck on “checking for additional content”. Could you let us know when did it start to occur? And also which edition of the game do you have?

    Feel free to get back to us if you've got additional questions.

  • azullFR
    Original poster 2412 posts

    @ubi-oxavo

    I guess that @orldan was not really stuck : it's just that loading times have become longer and longer with each update, as you can see in that Megathread :
    https://discussions.ubisoft.com/topic/99554/longer-loading-times-following-tu-1-2-2-post-here/1?lang=en-US

    In my case :
    I'm on PS4 pro :

    AC Valh 5.00 / Patch : 1.4.0 installed on Internal SSD
    PS4 pro CUH 7116B / FW:9.00

    SSD Samsung 860 EVO : USED SPACE = between 60% to 64% (depending of the number of the daily bugs to document....)


    Only "Searching for extention" loading time = 1min 38s

    Total loading time :
    From starting Valhalla Patch 1.4.0 to having a usable Eivor = 5min 33s...... with an internal SSD .... (up to 6 min !)

    Reminder :

    Old Test done the 3th May 2021
    From starting Valhalla Patch 1.2.1 to having a usable Eivor = 2min 41s


    Patch 1.4.0 note :

    Performance and Stability
    Improved performance and stability.


    it would be nice to merge this thread with the dedicated Megathread 🙂

  • Ryusennin
    164 posts

    @azullfr

    I'm shocked to hear that a PS4 Pro + SSD requires almost 6 minutes to load a save file, when my PS4 Fat + HDD already takes 5 minutes (which I thought was unacceptable).

  • azullFR
    Original poster 2412 posts

    @ryusennin
    yep ! impressive !

    I also had same reports from other PSN members = PS4 pro + SSD = 5 to 6 min to launch (searching for extension stage, wich increased by a lot with TU 1.4.0, is an online stage, so for this portion of the loading time, the SSD does nearly nothing)

  • alenn_masic
    1 posts

    Any progress on this? Still the same issue on PS4, it's unplayable.

  • azullFR
    Original poster 2412 posts

    there is another topic about loading time issues here :
    https://discussions.ubisoft.com/topic/122231/extreme-load-times/4?lang=en-US

    it would be nice to merge it here, hopping all these issues will be mre or less adressed with TU 1.4.1 ...

  • bitebug2003
    112 posts

    @azullfr Can't wait for this update 😊

Suggested Topics