ubisoft discussions

Quick Suggestions

  • Ubi-Mark.
    Ubisoft Support Staff 2623 posts

    Hello Vikings,

    Thank you for your continuous updates regarding longer loading times.

    I can see that the development team are still looking into this and as soon as we have an update, we will let everyone know through these forums and the patch notes.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • Ryusennin
    164 posts

    So the new 1.4.1 file structure (which required to redownload the entire game) seems to substantially improve the situation on consoles.

    On my standard PS4, loading a save file now takes 2 minutes instead of 4, from the title screen to ingame. That is certainly appreciable. However the DLC check on the start screen ("press X to start") still takes forever, almost 2 minutes. Origins and Odyssey in comparison are much faster.

    My PC version is marginally better, it now takes about 2 minutes to go from the start screen to ingame (instead of 2 minutes and a half), DLC check included. That is without any SSD.

    I haven't noticed any particular improvement in terms of texture/asset streaming, but I didn't have any particular problem to begin with (either on PC or on PS4).

  • bielik01
    1786 posts

    @ryusennin which PS4 version do you have?
    I own PS4 Slim, and this is what I got...
    https://www.

  • bitebug2003
    112 posts

    The Add-on Checking process is still ludicrously long (2 mins approx) which means we still have to wait at the title screen before we can load the game

    Checking for add-ons in Immortals Fenyx Rising is fast so perhaps this issue can be addressed in AC Valhalla

    The performance has improved for the rest - fast travelling is notably faster so thanks for that 😊

  • Ryusennin
    164 posts

    @bielik01

    Original ("fat") PS4.

  • azullFR
    Original poster 2395 posts

    PS4 pro
    AC Valh 5.10 / Patch : 1.4.1 installed on Internal SSD
    PS4 pro CUH 7116B / FW:9.03

    SSD Samsung 860 EVO : USED SPACE = between 60% to 64% (depending of the number of the daily bugs to document....)

    . Oldest Test done May the 3th, 2021
    From starting Valhalla Patch 1.2.1 to having a usable Eivor = 2min 41s

     . Old test done the June the 20th, 2021 :
    From starting Valhalla Patch 1.2.2 to having a usable Eivor = 5min 01s

     . Newest test done the 20th January the 5th 2022 :
    From starting Valhalla Patch 1.4.1 to having a usable Eivor = 4min 30s

    Timer starts here :

    and finishes here :

    Result :

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello there,

    I apologise for the delayed response. Thank you for taking the time to share your reports regarding longer loading times following TU 1.2.2., and for sharing updates following the release of TU 1.4.1 and the data restructuring. I'm glad to hear that some of you have seen improvements in your loading times following this update 😄

    I'd like to reassure you all that the development team are still investigating these longer loading times, and are taking a closer look at other ways in which these times may be reduced further. I've shared the updates you have posted within this thread with the team so they have visibility on this. Thanks for taking the time to share additional images and videos, @azullFR and @bielik01!

    Once we have any more updates to share from the investigation into loading times, these will be posted within this thread once they're available. Additionally, any future updates will also be published via patch notes within the News & Announcements forum.

    In the meantime, if you haven't already, we'd recommend that you try these basic troubleshooting steps for your platform if you haven't already. These steps help to tackle a number of common causes behind technical issues, such as longer loading times:


    We'd also suggest that you install the game on an internal drive, rather than an external one.

    If you haven't already, please can you also provide us with the following information:

    • How long was it before? How long is it now?
    • When is it the most significant (Fast travelling, River Raids, moving region via the Atlas, etc)
    • Does the game ever crash?


    We can then pass these reports to the development team to assist in the ongoing investigation.

    Thanks! 😊

    Official Response
  • azullFR
    Original poster 2395 posts

    @ubi-borealis
    many thanks to you for these news 👍

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    You're welcome @azullFR! 😄 Rest assured that once we have more updates to share regarding the investigation into the longer loading times you've been experiencing in-game, we'll be sure to post these within the forums.

    In the meantime, please feel welcome to share any updates or additional findings you may think are useful for the ongoing investigation within this thread.

    Thanks! 😊

    Official Response
  • SpirantCrayon22
    1878 posts

    I just did one, 4 1/2 minutes from clicking "y" to talk to Vagn to gaining control of Eivor at the dock without doing anything at the other end, only ending the raid.

  • TheNorfolkian
    1476 posts

    @spirantcrayon22 Is that still noticeably faster than before, though? I just did one on my XBox Series X and it took about a minute and a half from interacting with Vagn to quitting the raid for an immediate return.

  • SpirantCrayon22
    1878 posts

    @thenorfolkian

    I think that's about 40% less time than it was but still quite long. It's not a major problem, I've done that bit of the game enough so only engage when there's a weekly thingy.

  • Ubi-Froggard
    Ubisoft Support Staff 2717 posts

    Hey everyone,

    As mentioned in the patch notes here, the latest update today should have resolved issues with extensive loading times when transitioning from River Raids to Ravensthorpe.

    Please let us know here if you are still encountering this issue.

    Official Response
  • Ubi-Gizmo
    2297 posts

    Hey there @spirantcrayon22, thank you for getting in touch about the loading times. I want to assure you that this is something that our development teams are actively investigating. If we have any further information to provide, it will be posted below. Should you have further questions regarding this or anything else, please don't hesitate to reach back out.

  • nelsonk777
    1 posts

    @ubi-gizmo Hello. After Valhalla update 1.5.1 from last week on series X, it takes about 5 minutes to load the game, after pressing (A), the addon checking takes so long. Also there is continous problem with "ubisoft connect" [0x00000004]. It doesn't help when I reboot the game. Still no connection. 😞

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello there @nelsonk777! Welcome to the forums 🙂

    The dedicated teams are still investigating longer loading times, which is why there weren't any additional fixes for this issue included in TU 1.5.1. I'd like to assure you that the team are still looking into this issue further, though. Any future updates regarding loading times will be posted within this thread, as well as within the News & Announcements forum, so I'd keep an eye out for these.

    I'm sorry to hear that you're encountering a 0x00000004 error code. I'd recommend checking out our dedicated Megathread for this error code, as we've shared some updates from the investigation as well as further troubleshooting tips.

    Thanks! 😊

    Official Response

Suggested Topics