Welcome to discussions

Quick Suggestions

  • altaysevin
    Original poster 6 posts

    @ubi-mercury hi
    no nothing, just black screen and 1 sec shows save logo right bottom of screen (process of saving and starting new event and zone and loading) then it's crashed (like when you alt+f4 game) nothing shows. if you want i can take video and share with you.

  • Ubi-Mercury
    Ubisoft Support Staff 241 posts

    If you could please provide a clip, that would be great @altaysevin! Please upload the clip to YouTube as an unlisted video and send me the link to it here.

    Official Response
  • altaysevin
    Original poster 6 posts

    @ubi-mercury ok I record clip now

  • Ubi-Mercury
    Ubisoft Support Staff 241 posts

    Sounds good @altaysevin, keep me posted!

    Official Response
  • altaysevin
    Original poster 6 posts

    @ubi-mercury sorry it's late, my internet is not good (low speed)
    this link no difference with HQ setting or LQ setting always happen:

  • Ubi-Mercury
    Ubisoft Support Staff 241 posts

    Thanks for providing this clip @altaysevin! In order to investigate this crashing further, could you please try these troubleshooting steps to see if they help?

    Official Response
  • altaysevin
    Original poster 6 posts

    @ubi-mercury i will try them.

  • Ubi-Mark.
    Ubisoft Support Staff 1323 posts

    Hello @altaysevin,

    No worries! Please let us know if you're still experiencing this issue after performing all the steps provided 🙂

    Official Response
  • altaysevin
    Original poster 6 posts

    @ubi-mark sorry for late response, thanks for help issue is solved, I did this methods:
    change my windows to newest version : windows 10 pro 21H1 19043
    copy game SSD hard
    update graphic card to Nvidia 477.11
    motherboard drivers
    but I don't know which one solved crash
    and verify game files (it's found corrupted file and it's was low size file because download complete less than 1 sec).
    Thank you

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts

    Thanks for the update, @altaysevin! I'm glad to hear that the issue has been resolved and you're no longer experiencing a crash in "The Seas of Fate" 😄 Thanks for sharing what troubleshooting steps you tried as well. I hope you enjoy the rest of your Viking adventures!

    Official Response

Suggested Topics

Community Details

96
Online
192.9k
Users
32.5k
Topics
162.7k
Posts