ubisoft discussions

Quick Suggestions

  • lNyxiel
    1 posts

    I am having this issue also and i'm really not happy.
    I left to complete the story came back to complete the collectables and i did.. But no way have no way out of asgard, i have no wake up eye and you cant interact with the door.
    Extremely upset at the moment. I dont have a back up option to go too. as it will set my progress back several hours. Please can someone let me know when its been fixed Dx

  • Syphen75
    1 posts

    I finished the Asgard line up to Jotunheim, I then woke up and got the quest to collect the stuff to proceed to Jotunheim. I instead went back to Asgard to finish getting Ymir's Tear Stones. I now have no option to wake up on the map to get out of Asgard so no way to progress. The eye option that normally lets you wake up is missing.

  • VailLorian12
    1 posts

    So I finished everything in asgard and left then came back to asgard the next day and there is no icon to wake up anymore. my last save was from 3 days ago and I do not feel like restarting the game so I need some help to get out if anyone knows or if Ubisoft will fix this glitch fast enough so I can leave without losing everything

  • A Former User
    0 posts

    Hey there, thanks for getting in touch! I'm sorry that you are unable to leave Asgard. Would you mind posting a video showing that the "Wake Up" option is gone? What happened when you opened the door to Jötunheimr?

  • mostlyId
    1 posts

    @truejynxed You said it all. This was an idiotic design decision, and everyone from the writers to the developers to the QA folks should feel stupid for not catching this.

  • Humanklok678
    1 posts

    I went to asgard and did all the objectives and i went in the portal to jothunheim and then i went back to asgard and the wake up option is not on my map

  • StretchWiles
    19 posts

    @truejynxed 90 Power level is well off end game but there should definitely be a higher level warning but you can start the quest to close the gate and run past all the enemies with very little difficulty and then return to England

  • StretchWiles
    19 posts

    @humanklok678 once you've shut the gate I believe you hover the cursor over your player arrow on the map and it should give you the option (that's what I did) I missed the hint so it took me a few minutes to find it

  • Darren_Evans
    25 posts

    @truejynxed I just posted about this too. I'm power 54 and questing in Asgard was such a frustrating chore I reloaded to just before starting the In Dreams quest at Valka's hut. It's design flaws like this, coupled with a lot of animation glitches, quest bugs and LOD pop-in graphical jank that shows that Ubisoft game design, quest design and level design teams don't really put very much effort into 'attention to detail' refinement passes of gameplay during development before releasing their title.

  • TH3R4BB1T
    31 posts

    I was now on a point to drop the game in the bin, I expected bugs and such, but this is the worst trap quest ever.

  • merckk
    15 posts

    @th3r4bb1t i just started this but i was able to go back out after finishing the first quest of closing the door the frost giants were using. Is there something else later in the game that forces you back to asgard?

  • Gearoidm13
    1 posts

    Is there any fix for this I tried loading previous saves but it still just remained at Asgard. Now I’m stuck with too low a level and unable to leave the level or even change the difficulty

  • Prasath.Sp10
    3 posts

    Same Here. Came back for collecting Ymir's Stones. No Manual Saves. No Eye icon to go back. Only way is to load Episode Save by which I will loose all collectibiles and 7hrs of Gameplay.
    @Ubi-Spud Please Fix this issue soon. I can't Play. My Stream Viewers are waiting 😞

  • Prasath.Sp10
    3 posts

    I tried to upload a video. It says "You do not have privilages". So Im uploading ScreenShots.


  • Prasath.Sp10
    3 posts

    Video G-drive Link: "https://drive.google.com/file/d/1W9bFyLU-RZcoqZXuOqh4CKTBJuvcMlhx/view?usp=sharing: (https://drive.google.com/file/d/1W9bFyLU-RZcoqZXuOqh4CKTBJuvcMlhx/view?usp=sharing)"

  • SoEnguy
    1 posts

    @ubi-spud Same issue here. Done the quest line, my next goal was to go to Jotunheim, but I was missing 1 wealth, so after getting back to Ravensthorpe, i went straight back in. Door is closed, and no wake-up option on the map.

  • YazX_
    193 posts

    having same issue, here is the steps to reproduce (at least what i did for it to trigger):

    1. Complete Asgard quest line and exit through the door.
    2. Go and gather Materials for Valka's next potion.
    3. Drink potion and travel to Jotunheim.
    4. Wake up by click the eye icon and leave Jotunheim.
    5. Drink the Asgard potion again.

    you will travel to Asgard and get Stuck, no Eye icon to wake up and no door to leave, please check the image below:


  • ArthusDrake
    4 posts


    I'm in Asgard @ power level 39, I could close the gate avefter the fight and got a message that left too fast about waking up from the dream, lafter a little search, I went to the map and there is an eye @ Heimdall's tower to wake up :D.

  • Kau_adh96
    12 posts

    Ive had this problem too, i was power lvl 45, I managed to finish the mission by running straight to hemdalls door and closing it hoping the enemies wont attack, and I was able to close the door and the mission ended, and i was able to wake up from asgard.

  • Reboir24
    2 posts

    I had the same issue, I found the yellow door near Heimdall's tower by chance. In front of that door you can activate "leaving asgard" option by pressing E button.undefinedundefined

Suggested Topics