Welcome to discussions

Quick Suggestions

  • goodsoup83
    4 posts

    @ibn__

    God bless you!!!

  • guest-WhRop36F
    1 posts

    This sucks. Lost 4 hours of gameplay because I glitched in Asgard and couldn’t wake up and drink the other potion. Please fix very dumb bug.

  • mark_a_429
    1 posts

    @epikpandazz I am in the same boat, that door won't open, there is a white spot in front if I use odin's sight but it doesn't let me interact with it.

  • Alaniata
    5 posts

    Seems like my game is now unplayable.
    I went back to Valhalla after completing it to clean up the tears.
    Now I can't leave. The icon to wake up is simply gone. Plus the last tear on Lyngvi Island is behind an orange barrier so I can't even do anything while stuck here.

  • Alaniata
    5 posts

    @alaniata seeing as i can't edit OR delete this:

    Brainfarted, I of course mean Asgard instead of Valhalla. Stuck in Asgard

  • Alaniata
    5 posts

    @ubi-spud This is still happening, any update on a solution?

  • ElderbarkMage
    1 posts

    Went to Asgard by mistake the second time around to progress with Going Deeper. (I know that there were two potions on the table. Poor design led to wrong choices on my part.) I am stuck in Asgard with no way to wake up. Not going to play again till this is fixed.
    On Ps4 btw.

  • mauigreen
    1 posts

    @guest-whrop36f same here

  • mactheappleking
    1 posts

    Gave Velka the herbs for the quest Going Deeper. I drank the wrong potion and ended up in Asgard.
    The eye icon on the map that lets you wake up is missing, and when I physically approach the door at Heimdall’s tower, the prompt to “wake up” is similarly missing.

    I noticed my pc needed an update, so I’ve updated and restarted the computer. I also went to the Ubi Connect app to verify my game files in case something needed to be repaired. Issue persists.

  • Ragerian
    1 posts

    I went back in to grab some tears and now I'm stuck in Asgard with no eye icon to get out. I verified files to no avail. Why would you allow people to go back into Asgard if the exit feature is broken?

  • Ubi-Swaggins
    Community Manager 429 posts

    @emmiebabyblue I am sorry to hear that you are encountering this issue.

    Could you provide us with a brief video showing this in action from your game?

    Official Response
  • Ubi-Baron
    Ubisoft Support Staff 789 posts

    Hi guys,

    Thank you for reporting this to us.

    We are aware of the Wake Up option being missing if you have completed the main story and then returned to Asgard, there should though be a door that allows you to return to England at Heimdall's Tower.

    Can you try heading there to interact with the door and see if that allows you to leave?

    Official Response
  • Ubi-Baron
    Ubisoft Support Staff 789 posts

    @ElderbarkMage Thank you for reporting this to us.

    This is something that the team are aware of, and is being looked into. One think that you can try is heading to Heimdall's Tower, as there should be a door there that allows you to return to England.

    Can you try interact with that?

    Official Response
  • scarfoxnyeh
    13 posts

    I made the same mistake, just had to re-load a save before entering Asgard... try that you might have an autosave in the settlement just before Asgard 😕

  • bfoo
    4 posts

    I have the same problem. I am stuck in Asgard. The eye symbol just does not appear. I returned to Asgard, because I thought I took the wrong turn when heading for Jotunheim. I don't want to load an old savegame. I would loose too much progress.

    This is F'ed.

  • oscartef
    1 posts

    The official answer is amazing. It is Your game. You should see that there is no interaction possible with the door once you go back in Asgard, because that bowl was still on the table of Valka!
    There is a autosave in the middle of the boss fight right, but not a single one after that. I had finished the cave for the second plants and had to do all again. Poor design for the bowls. Nothing related to the great game. But seriously fix this. There is a way to gat stuck on Asgard with no way to go back except from reloading a previous save, this is game breaking.

  • ngurto
    2 posts

    Same. I'm stuck in Asgard. Completed everything. started the Going deeper quest and i'm back in Asgard, with no "wake up" button and nothing to do. Only option I see is reverting back and losing 3 hours of play....

  • logxn-rekt.us
    1 posts

    Note: Sorry for any misunderstandings I‘ll try my best
    Hey Guys,

    When I first came into Asgard I made it my mission to complete Asgard before awaking from the dream.
    In the last mission (Not the boss fight!) where you go trough the big door and awake from the dream, I was talking to the lady to finish the mission.
    Instead of continuing in Englaland I went ahead and drank the dream potion again.
    After traveling back to Asgard this is where I have a problem now.
    I am stuck.
    After googling I found out there is one last mission in Asgard you can only do when progressing in Englaland.
    I cannot start this mission because I am not that far into the story yet.

    Going back to the door, it will simply stay shut. Opening the map does not give me an eye icon to wake back up.

    The only thing left for me to do: Reload into a 2hr old savegame, and losing all the progress I have made in Asgard.

  • SwarleyBrown
    2 posts

    On Xbox Series X: I had a few Ymir’s tears to get on Asgard so I wanted to try to get them all (there’s still one I wasn’t able to get, but that’s not really of concern now). However, when I tried to leave Asgard both the “eye” symbol and the open to press the action on the golden door have disappeared and I’m not able to leave.

    I’d really hate to have to restart my progress on the game — has anyone else had a similar issue?

  • sam1987nr2
    2 posts
    leave Asgard both the “eye” symbol and the open to press the action on the golden door have disappeared and I’m not able to leave.

    Yes similar but the door worked when i went there eventually. The whole area isn't working after I defeated the builder and was stuck with no way out his prison beside fast travel.

    I stopped playing a few day because Uconnect and other platform issues they have ( payment problems , customer service down, Uplay and Uconnect account merging (inc U coins, discounts, dlc still missing or used but didn't receive). So the client U connect app got an update the game did not. And while i had defeated the builder and needed to get out. I entered and yes Now it says i didn't also all the fast traveling point don't work. So i tried to get in the magic prison with no succes, trigger NPC's old and new ones, resync the viewpoint, did some other side quest. nothing changed. Then the door or wake up button on the map didn't work and i started to get nervous and [censored] off. ( why do man saves get auto overwrites sometimes ?) So i went do the door didn't see the buttonicon for several minutes, But got it eventually tried other angles of view and got out and never return.

    There are a lot of bugs you can create/have and while they say reload officially My man saves get replaced by a couple off auto saves after events. So ...

Suggested Topics